no post screen

Forum discussion tagged with no post screen.
  1. W

    Question new pc stop working after 2 days

    just got my new pc working after 1 day of tweaking new bios for b550 for ryzen 5 5600x specs: Cpu : ryzen 5 5600x stock motherboard : asrock b550m steel legend ram : 2x8gb 3600mhz corsair rgb pro psu : corsair tx750m gpu : gigabyte g1 gaming gtx 1080 i have just changed my whole system except...
  2. LINADIA

    Question Pc won't boot, no POST

    Hey, forum I was just casually playing a game on my pc today, nothing interesting really. But then my pc lost power randomly and bricked. Before that I kept looking at voltage and temperatures - they were okay. No overvoltage, no overheat. Cpu runs at 65° max, GPU at 50-60° at 70% fan speed...
  3. T

    Question New PC build Unknown Problems!

    Here is the situation. I am currently putting together a new PC build using an older working motherboard and CPU. I have made the build using the proper connections for wires and even watched multiple youtube videos (read some forms) regarding both the build and the problem. Now I have got...
  4. R

    [SOLVED] My PC Black Screens after saving BIOS

    Hi, I have a gigabyte B450M H. I just overclocked my Ryzen 3 3300G to 4ghz (which it is capable of running), went to save the BIOS, the PC Black screened and didn't POST. I've taken out the CMOS Battery and reset the BIOS and the PC seems fine if I don't touch the BIOS at all. As soon as I enter...
  5. R

    [SOLVED] POST Problems - Starting & Stopping

    Good evening. So I just finished building a new PC, just for ordinary everyday use, no gaming GPU or anything. Specs are as follows: ASRock B450M Pro4 Ryzen 5 2600 G.Skill Aegis DDR4 3200 (8GB, 2x) Deepcool Gammax 400V2 Red Corsair CX450M Fractal Design Core 1100 case 2 Case Fans (1 intake...
  6. Miniroast

    Question Bought new ram, pc won’t post

    So I recently bought 16gb of Corsair vengeance rgb pro 3000 mghz ram to make my Pc prettier, but when I installed it, my pc would no longer post. So I took the new ram out, and went back to the old ram, but the pc still wouldn’t post. I have a x99a raider motherboard with an i7 6800k cpu. Any...
  7. jiwoonhan

    Question PC wont go into BIOS nor POST

    So I recently bought myself a brand new CPU, motherboard and RAM and when I installed everything, the computer would turn on along with all the RGB (Fans and RAM) but the pc wont output on a display. All the parts beside the CPU, Motherboard and RAM have been in use so I know there is no problem...
  8. D

    [SOLVED] No Video Signal Output

    Hello. I am having an issue with my pc. I recently got the BSOD on my computer and it is not outputting any video signal out. I RMA'd both the motherboard and the CPU, and bought a new PSU, but the problem persists. I am not even able to get into the Bios. When I power on the system, the...
  9. H

    Question PC starting but no display please help 🙏

    Hi, Guy's my PC is starting fan spinning but no display I checked my ram, graphics card, monitor, cables and Psu on my friends PC everything working good but I don't know what's causing my PC to not start I even clear the CMOS multiple times still no luck and someone please help me with this...
  10. G

    Question Newly built pc can't turn off, no beep on startup, no post

    Hi there, I'm a very new bc builder, as in this is my first ever build. I followed the numerous videos online, but still, the system will not start properly. However, the fans seem to run. There are a few problems: 1) I can't turn the computer off, only on. The power button on the case does...
  11. T

    Question My PC is not showing a display after swapping cases

    So i swapped cases for my PC to add better cooling/airflow, as well as replacing my old HDD (storage only), and while i assumed i handled every component gingerly while transferring cases hoping minizing risk of an issue like this. Well, i got it anyway. So with everything plugged in, the PC...
  12. C

    [SOLVED] Computer working for years now sending no signal to display

    I just bought my best friend's homebuilt computer which has worked for years, yesterday we booted it up and reformatted the drives with no problems. Then I took it home and installed some of the har drives from my computer and tried to boot it up but now it sends no display to my monitor...
  13. CFFA17

    [SOLVED] No post with a different CPU!

    Specs: I have a Dell optiplex 390 with 2x4gb DDR3, Sapphire Nitro R9 390, i5 2400, 1x 500GB HDD, 1x 1TB HDD, and a 550w power supply running Windows 10 Pro and A14 BIOS, which appears to be the newest version for the motherboard. Luckily I've been able to shovel these parts together for under...
  14. W

    Question PC will not post, no signal, no beeps

    Hi there, I have been having this issue for quite a long time now. When I turned on my pc, there was no post at all to the screen, I have now done many troubleshooting methods to try and fix this. Replaced the power supply (got it rma) Got new ram (went from 3000 to 3200) Returned the...
  15. MrTxMx

    Question Just built a pc but only posted once then never again after I unplugged it

    I’ve recently just built my first pc but it will no longer boot no mater what I do Parts: Asus ROG Strix b450f Ryzen 5 2600x EVGA GeForce 1660 super Corsair vengeance lpx 16gb I’ve been trying to fix it for the past week and nothing seems to work. The system powers on properly with fans and...
  16. Korican64

    Question Dram amber light on mobo

    So my computer wont post and is stuck on a black screen. On my mobo, the dram led is lit amber and wont go away. I overclocked my ram to 3200 w/ xmp. I did not mess with any other settings in the bios. When I played escape from tarkov and streamed at the same time, that's when my computer...
  17. A

    Question No POST/Video Signal, no Beep

    Hi. My father has an Asus P8H77-M LE with Intel i5 3330 and 16gb of RAM (two sticks of 8gb). It was working perfectly but now it isn't showing any video, there is no post. I bought a speaker to see what the machine has to say, and when everything except the CPU/Fan is plugged out, it give's me 1...
  18. V

    [SOLVED] PC won't post after re-installing Noctua NH-D15 cooler (metal clips touched the GPU?)

    Hello, how are you? My PC was running fine and then I've noticed one of the two fans of the Noctua NH-D15 was not spinning. I've opened the case and just tried to figure out if the connector was not plugged well, but in the process, I think one of the clips just touched the back panel of my GPU...
  19. M

    [SOLVED] First time Intel build not sending signal to monitor

    My son and I just completed a Intel build (we are first timers). Everything seemed to be going fine until we attached the monitor and started up the PC. Seems like there is power to the mobo with both the CPU fan and the case fan running. I’ve tried pulling out the GPU, no change. I’ve tried...
  20. andy7561

    Question New components but no post on my PC.

    Hello, I bought some new parts for my PC; a motherboard (Prime B450M-K), CPU w/ stock cooler (AMD Ryzen 5 2600), GPU (GIGABYTE GeForce GTX 1650) and RAM (Team group elite plus 8GB). I connected all of these components to my pc and turned it on. The pc turned on fine and the fans started to...
  21. Jaysif

    Question Rog Strix B450 Dram LED blinking, won’t POST any ideas?

    My PC -> MOBO: ASUS ROG Strix B450-F Gaming Motherboard (ATX) AMD Ryzen 2 AM4 DDR4 DP HDMI M.2 USB 3.1 Gen2 B450 CPU: AMD Ryzen 5 2600X Processor with Wraith Spire Cooler - YD260XBCAFBOX GPU: MSI Gaming GeForce GTX 1660 Ti 192-bit HDMI/DP 6GB GDRR6 HDCP Support DirectX 12 Dual Fan VR Ready OC...
  22. AlexDura

    Question Pc turns on for one second and shuts down

    Hi guys , today I was playing star wars battlefront 2 , had my gpu overclocked to 4.5 ghz an i5 6600k paired with gtx 970 overclocked. Suddenly PC went into blue screen and restarted but when it went back on everything was running besides the gpu ( first 10 seconds spins then slowed down till...
  23. justsp

    [SOLVED] Possibly damaged motherboard - troubleshooting

    I have an ASUS P8B75 M-LX, and a Gigabyte GTX1060. One of those two must have been burnt. I hadn't cleaned the inside or change thermal paste for some time, so it was time for some cleaning. I removed everything, cleaned the dust, changed the paste, connected them all again, checked one final...
  24. S

    Question Is it my GPU or my motherboard which died? How to separate the issue?

    Good day all, yesterday evening during some CAD work, my PC crashed and left me we a red'ish left and a black right screen. Powering on again worked after a couplel of tries, but tomorrow my PC won't post at all, can't even get into bios. Naturally I thought it might be my GPU that got fried...
  25. L

    Question Not boot then goes in boot loop

    So I building a new pc and when I finished I went to turn it on and it turned on with no post then turned off after 30 seconds. Then it would go into a boot loop. I tried resetting everything literally I mean everything and jumped the cmos and took out the bios battery then put it back in but...
  26. N

    [SOLVED] help, my pc isnt booting, no post screen.

    I dont know in which category to place this in but anyways. I recently built my computer, and when i turned it on, the cpu fan started, all the rgb started, but the case fans didnt spin at all, CMOS lights red on VGA, DRAM, CPU, BOOT. No post screen or anything.
  27. B

    Question No post on ASUS ROG STRIX B350-F Gaming Motherboard barebones setup

    Hey everyone, I have watched every YouTube video on this topic, and read every forum. I hope someone can help! Here's the setup: ASUS ROG STRIX B350-F Gaming Motherboard (New) Seasonic Focus 750W Power Supply (New) AMD Ryzen 7 2700X CPU with included Cooler (New) I assembled this thing...
  28. M

    Question MSI B350 Tomahawk no display

    I just finished a build with these parts Ryzen 2600 MSI b350 tomahawk Rx 580 16gb g.Skill RipJaws V 2400 There is no output on the graphics card and none of the debug led are on. I have tried to change the CPU to an a6-9500 but still no display. I don’t know how to fix this and any help is...
  29. 1

    [SOLVED] PC wont post. when I start my pc my fans start spinning but my GPU and case fan switch off straight after.

    I need your guys help. I recently tried to upgrade my pc with a new cpu i5-9600k. Because my mother board was outdated I also had to me one of those so the socket fits: Gigabyte - H310M A Micro ATX LGA1151 Motherboard and new RAM: G.Skill - Aegis 16 GB (2 x 8 GB) DDR4-3000 Memory. when I put my...
  30. K

    Question Computer not posting

    I've had my computer for a little over a year. It's brand new and I built it myself. It's been preforming fine expect that when I would be unplugged or when the power supply would be shut off, the computer would be stuck in a boot loop. In that case, I would just keep turning it on and off until...
  31. D

    [SOLVED] No Post No Beep

    I'll just provide the TLDR version of my story... I am building my first computer and can't get a display output. Tried only with HDMI (I don't yet have a monitor) on two different TVs. Fans spin and MOBO lights up. No (or not enough) power to the keyboard to illuminate its backlighting. I have...
  32. C

    My 'G' key is super sensitive

    Even if you slightly pass your finger over the 'G' key, it types 'G' and sometimes spams 'G' like crazy. Is there any way to fix the sensitivity on my 'G' key? I'm on a laptop with a built in keyboard. As an example, I will write sentences without editing the 'G's out of them. GThis is how...
  33. T

    DirectX 10.1 on a budget

    If anyone can give me any suggestions or point me in the right direction it would be greatly appreciated. I'm basically looking for the most barebones affordable GPU (either geforce or radeon) and the only requirement is that it be compatible with DirectX 10.1. This will not be used for gaming...
  34. V

    Issues with AMD R9 290 and AMD drivers

    So I have a r9 290 and I can't upgrade drivers after 14.4 this version kind of works but I get a BSOD once a week with a message 0xa0000001 any newer drivers than the 14.4 installation goes well with a success and then it asks me to reboot and I press ok, the PC boots, I log in to windows and...