retro gaming

Forum discussion tagged with retro gaming.
  1. 888.jfa

    Question Dosbox EXE issues

    I've been trying for days to get an old windows 3 game to install (Gahan Wilson"s ultimate haunted house) with dos box and I can't get past the "this needs windows" error. I know people have used dosbox to emulate this game before, you can stream it on certain sites, but I can't get it to...
  2. D

    Question Can I run my MSI 750 Ti to my ILO IWF2706 without a converter?

    I want to run my MSI 750 ti to my ILO IWF2706 CRT with this cable https://misteraddons.com/products/video-cables-hdmi-scart-ypbpr?variant=39633472225413 VGA to YPbPr Is this possible without a converter?
  3. M

    [SOLVED] Retro Computer Question

    I have acquired a eMachine eMonster 550 from an estate sale. I like to pretend my 90s knowledge is superb but it's actually severely lacking. I know the machine has 128 MB of RAM, a Pentium 3, a 15 GB HDD, and a Nvidia Vanta. My goal is just to play games made from the 1993-1999 time period. I'm...
  4. C

    [SOLVED] retro agp graphics card recommendations

    Hello, I’ve recently been looking for a retro agp graphics card for my pentium 4 system (2.4ghz 1gb ddr ). I have an offer of 30$ for a used Radeon 9600 pro I’m not to sure if this is a good deal? I would like to find something for as cheap as possible less than $30 preferably, any recommendations?
  5. Jda2000

    Question Very minimal system? 1

    Preview Just registered today. Hope I'm entitled to one newbie question. If I only want to run Origin and play Red Alert 3 and CnC 3 Tiberium Wars 3/Kane's Wrath at 1920x1200 what's the minimum desktop PC that I can get away with that won't burn up in a few years? Thanks in Advance!
  6. ExtreamChaozZ

    [SOLVED] Atari 2600 Power Supply

    Hiya, I am looking at picking up a power supply for my dads old Atari 2600 so we can get it up and working. I have found out that i need a 100V - 240V ~ 50Hz 9W input and a DC 9V 500mA output. I have found similar plugs with the correct input but the output is rated for 1A not 500mA (0.5A)...
  7. D

    Question Retro build doesn't detect newer gpu and wont post.

    A8N32-SLI Deluxe Athlon 64 3500+ 2 GB DDR-400 750W PSU HD 6670 So i'm building this older pc for playing some period specific titles like half life 2 and fear, but the problem i have is that i couldn't order my planned gpu because of the virus and i resorted to using this 6670 that i had lying...
  8. A

    [SOLVED] I'm trying to find a old pc game about slicing up the screen

    I remember I used to play this old pc game that had a unique mechanic. The player would move along the edge of the playable area where it was safe, but the goal was to move inward and cut up pieces of the area while not getting touched by enemies that were bouncing around inside the area. You...
  9. D

    Question What to do with a Commodore VIC-20

    I found an old Commodore VIC-20 in my great aunts garage. It still powers on and puts out image. I don't really know what to do with this thing, it's nearly twice my age. Is it worth anything? Anyone want it? Have any suggestions?
  10. Discussion Community Questions: What's Your All-Time Favorite GPU?

    We recently updated our GPU Performance Hierarchy to include a few brand-new cards, which got us thinking: What’s our favorite graphics card of all time? Everyone has their own personal golden age of gaming. If you were born in the late 1970s, perhaps it was the DOS era of PC Gaming known for...
  11. K

    No Display to Screen

    Hello I am extremely confused by this problem. So, I have a dell vostro 260 that's paired with a gt 1030 and has a motherboard of 0gdg8y 1155 chipset. When i power everything on the fans spin for a second but there is no display. I bought a new motherboard and that didn't seem to do anything...
  12. I

    Router wont connect to the internet

    Hi there, I have my router working perfectly for a couple of months now, however sometimes my router stops working and then gets back to its senses, this time its kind of stuck and wont work again “The led on the router that indicates internet connection gets red”. I have configured 2 of my...