RX Vega 56

Forum discussion tagged with RX Vega 56.
  1. C

    Question Weird electrical noise from graphics card?

    A couple of months ago, I bought a Sapphire Radeon RX Vega 56 Nitro+ 2xHDMI 2xDP 8GB to put in a Razer Core X for my Mac. It has been performing really well, however, when I put heavy load on the graphics card (like a graphics-intensive game for example) it makes this really weird electrical...
  2. S

    Question Second hand Vega 56 and 600w PSU

    I'm looking for a slight upgrade from my current 1060 6GB Zotac. My current setup besides the 1060 is a R5 1600+16gb+256 sata ssd+2tb HDD, and the PSU is a Super Flower Silver Green 600w. (https://www.super-flower.com.tw/product-data.php?productID=69&lang=en) So far I'm having no stability...
  3. A

    [SOLVED] If a PCIe slot is dead can the mobo still run as normal?

    I am asking as I have gpu issues where it is not being detected. Apologies if this is not the right thread but I am currently concerned about my mobo and so am asking in here. With the GPU seated and powered it runs, but if plugged in to the monitor computer starts but no signal is sent to the...
  4. H

    Question Will My Corsair TX650M Run AMD Vega cards?

    Hi, I have a Corsair TX650M in my build that I bought recently because my last PSU failed. I saw it had really good ratings and the 650 watts is plenty for my current specs. However, I am thinking of upgrading my RX480 to either a Vega 56 or 64. I'm just wondering if it is wise to attempt to run...