Question „Glitches“ after Ryzen CPU upgrade?

Apr 10, 2022
10
0
10
0
Problem happens after I upgraded CPU, from ryzen 1800X to ryzen 5700G.

Every couple of hours I experience so to say „glitches“ as I watch some video or listen to audio files, or play some game. For a second or two the sound freezes.

It is not situation where I overwork the system, it is normal everyday use.

It happens completely random, so I dont know why and how and wouldn't know how to replicate.
Why I am worried because it never happened with old CPU, and now it happens almost every day. Since I didn't make any other change to system, I suspect the CPU?

Is there a way to check what has happened in that exact moment, in some windows logs or some other way? I checked Event viewer but I dont find any error related to that time. Is there a way to see in win10 what makes this interruptions?

I use win10, updated, Asus PRIME X470-PRO, Samsung SSD 970 EVO which is in good health, HyperX 32GB RAM, ATI AMD Radeon (TM) R9 200 Series. I did full uninstall GPU drivers, and install new.
It is not overheating, I didn't OC, and use all default settings in BIOS.

I run some test. Memtest64 for an hour without errors, but next time BSOD with message „kernel security check failure“.
After that I run
sfc /scannow
Found errors and fixed them, so BSOD might be because of that?

Then I checked chkdsk C: without errors and
Dism /Online /Cleanup-Image /CheckHealth

then I test boot memtest86, for 2 hours without errors. I know it is recommended to test for longer but I cant do that now.
Also I tested with Prime95 for 2 hours without errors.

Also I change the system performance options to adjust for best performance for Background services, but nothing changed.

I wonder is this CPU is garbage. Because as I said it never happened with old CPU.
How to find out what is causing this problem?
 
Apr 10, 2022
10
0
10
0
I updated to latest BIOS before upgrade. chipset driver also.
Right now CPU temp is 40-42C (107 fahrenheit). When I put it to test it goes close to 70Celsius.
 
Apr 10, 2022
10
0
10
0
It is still happening.
I find out in AMD chipset driver, that "AMD processor power Management support" is not installed, even I completed installation before. Could that be causing this glitches?
All other driveres are installed except that one.

I tried to fix that by reinstalling, but it keeps failing to install.
I find many posts about that problem all over, but I test all solutions without success. Most of this solutions are couple of years old. Anyway, I tried them all, tried deleting C:\AMD, MS tool for uninstalling, and every other way that I find, but this driver wont install.
Anyone have the same problems, and found solution?

View: https://imgur.com/a/Vi18ik4
 

ASK THE COMMUNITY