Question 1 Front USB 3.0 Port not working

Jan 24, 2020
1
0
10
0
I built my PC in January of last year. About a month later I found out that my Left 3.0 USB port doesn't work on the front of my case. I didn't mind it since I only used one USB port in the front. But now, I need that port since all the other ports are plugs into something. The right one works perfectly fine with no issues. But the left one doesn't work at all. When I plug something into it the Windows message and noise doesn't pop up and windows don't read what is plugged into the USB. I went to device manager and nothing was wrong there. I checked if it was a hardware issue but my 1 USB connector was plugged in just fine. It only uses one connected to the motherboard for both USB 3.0 port I'm pretty sure. I updated all USB drivers and it didn't work. What can i do to fix this issue?


CPU: Intel Core i7 8700k
GPU: NVIDIA GeForce GTX 1070 Ti
Motherboard: MSI Z370 Gaming Plus (MS-7B61) Coffee Lake Chipset
RAM: 2x 8GB Corsair DDR4 RAM 3000 MHz
Storage: Samsung SSD 970 EVO 500GB, WDC WD2003FZEX-00SRLA0 (WDC 2TB HDD)
 
Sounds like one of the front usb sockets is defective.
You might try to reseat the front panel usb cable.
They are quite stiff and really do not seat well.
Try to keep any bend out of the cable.
Possibly, the cable itself is defective.

If no joy, you can buy a pcie add in card with several usb ports and install it in your motherboard.
It could be a usb3 adapter if you think it is the motherboard pins tat are bad.
Such a card may also have some added usb ports to plug in to the rear of the motherboard.

Lastly a usb hub may serve to give you several usb ports on your desk.
 

ASK THE COMMUNITY

TRENDING THREADS