Question 1 Long beep followed by 3 short beeps + I have display!

Mair0n

Commendable
Aug 3, 2019
47
2
1,535
0
Hello everyone,

First of all this is my pc specs:
GPU:ASUS ROG Strix RTX 2080 Ti
CPU:Intel core i9 9900K
MB:Asus ROG Strix Z390-F
RAM:32GB Trident-Z Royale 3200
PSU:1050Watt

Recently I find out that my MB speaker didn't connect properly!
After that I connected it to MB correctly, Sometimes I hear 1 long beep followed by 3 short beeps with no display BUT for 2-3 seconds!
Then everything backs to normal What's the problem?
 
According to your motherboard's manual it means no VGA detected.

Does your GPU perform as it should?

I would reseat the GPU in the slot and if the problem continues I would contact Asus for further troubleshooting. If you still have warranty, try to solve it before it expires so you can RMA a possible faulty hardware.
 

Mair0n

Commendable
Aug 3, 2019
47
2
1,535
0
According to your motherboard's manual it means no VGA detected.

Does your GPU perform as it should?

I would reseat the GPU in the slot and if the problem continues I would contact Asus for further troubleshooting. If you still have warranty, try to solve it before it expires so you can RMA a possible faulty hardware.
Yes GPU works perfectly without any problem.
I reseated it before but nothing changed!
the weird thing is that I have display! + these beeps
 
In the bios, there should be a setting to designate the discrete pcie adapter as primary.
I suspect that the bios is not automatically switching when the discrete card is detected.
Possibly, there is a motherboard bios update that addresses this.
 

ASK THE COMMUNITY

TRENDING THREADS