Mar 30, 2015
I have MSI x570 Gaming Edge Wifi motherboard running 2 GPUs:

  1. GTX 970
  2. RTX 3070 Ti (Zotac AMP HOLO)
I will describe my situation and how I got here.
I was previously running just 3070, and there is no issue with this card when its running in primary PCIe. And now idea was to move it to secondary PCIe and make it exclusively passthrough from my Linux to Windows VM. Everything worked flawlessly - I got it working exactly as I wanted and games were running smoothly in my Windows VM. But from very beginning, since I moved 3070 to secondary PCIe, 1 of its 3 fans always start to run at full speed.

That 1 fan behavior is following:
  • initially runs at full speed when I boot OS (for about 1-3mins). And this is just 1 fan. Other 2 fans are usually idling or barely spinning. For example, in primary slot it never goes full-speed.
  • runs at full speed when I launch and play games
  • runs at full speed at random times for about ~30sec when PC is idle.
  • fan speed cannot be controller using MSI Afterburner - only other 2 fans are affected when I change settings.
So I started digging this issue, tested different options, settings, configuration, but without a luck - here is what I already tested:
  • Used 3070 without VM and passthrough. Dual-booted and switched from Linux to Windows. Same behavior in both Linux and Windows. 1 fan is uncontrollable , so at this point I excluded VM issue.
  • Updated drivers / Rolled back to older drivers.
  • Updated BIOS.
  • Removed my secondary M2 (as I understand, it shares PCI lanes).
  • Tried switching PCI lane combinations (x16/x8+x8/x4+x4+x4+x4).
  • Switched places for both GPUs multiple times.
I suspect 2 things which may cause this issue:
  1. Specific glitch/bug on my 3070ti when running in secondary slot, because there are no such issue when I use 970 as secondary GPU. But I cannot confirm this as I don't have another 3070.
  2. Motherboard limitation? When I look at board specification, it says Running at x4, so maybe some issue when 3070 is running in x4 mode? But then again, as I mentioned, I successfully made it passthrough to my VM, and gaming experience was top-notch smooth.
But maybe anyone here knows what could be an issue? Ideas or possible solutions?
Last edited: