Question 1 of my front panel IO USB 3.0 Ports Dont Work

Jason H.

Honorable
Oct 20, 2013
1,469
75
11,590
61
Something I have neglected for awhile but am finally asking about, is when I got my case 1 of the front panel USB 3.0 ports didnt work. I didnt discover this until after the return period so not really sure if it was always like that or it somehow broke but 1 day when I went to plug something into it, it didnt work, but the one right next to it did.

So I opened the front panel and took a look around and it looks like both ports are soldered onto the same circuit board.

My Questions



  • Is there any troubleshooting I could do to try and make it work?
  • If I need to replace the port, will I obviously need both ports since its on the same circuit board?
  • Lastly, is it easy to replace lol?
Thanks ahead of time! (case at bottom of specs)

MOBO: MSI Tomahawk B450
CPU: Ryzen 7 3800x (4.3ghz 1.375v)
Cooler: Scythe Mugen 5 Rev.B
GPU: Gigabyte RTX 2060 Super OC 3x Windforce White (8pin only version)
MEMORY: HyperX RGB 2x8gb DDR4 3200mhz (OC'd)
Storage: Samsung 860 Evo 250gb / 500gb Seagate / 1tb Samsung 860 Qvo
PSU: Corsair cx550m
WIN: Windows 10 Pro
Case Cooling: Antec Prizm 3x 120mm rgb case fans with controller and 2 RGB strips / 1 default 120mm case fan
Case: Cougar MX330
 

daniel_542

Commendable
Jun 10, 2017
176
3
1,715
12
Check the port on the motherboard - I recently saw one that had a bent pin that caused exactly the same fault. Once the pin was straightened, both ports were working.
It's a 20 pin port in two rows of 10 but one pin on the enf of one of the rows will be missing anyway.
Like this:
https://images.app.goo.gl/Gzr7J3mifdURcbdt8

Make sure the 19 pins are straight and all present. If so, check the USB ports themselves for damage too as it might be a bent pin in the port itself.
 

daniel_542

Commendable
Jun 10, 2017
176
3
1,715
12
No physical damage to the ports on the front of the case?
Is there a loose connector on the front panel end of the wire inside?
Are both ports on the same motherboard header cable or do you have more than 1 USB 3 header cable from the front ports?
 

Jason H.

Honorable
Oct 20, 2013
1,469
75
11,590
61
No physical damage to the ports on the front of the case?
Is there a loose connector on the front panel end of the wire inside?
Are both ports on the same motherboard header cable or do you have more than 1 USB 3 header cable from the front ports?
no physical damage, connections secure, and they share the same motherboard header.
 

ASK THE COMMUNITY

TRENDING THREADS