Question 1 out of 2 sticks of RAM detected

Mar 31, 2020
2
0
10
0
Hi!

I recently upgraded my PC, went from Intel to AMD. New CPU : Ryzen 7 3800x. New Motherboard : Gigabyte X570 Gaming X. On my last build I had 2 x8Gb G.Skills Ripjaws DDr4 2400 and worked fine. But now only 1 out of 2 sticks is detected.
A. I tried Windows Memory Diagnostic with no results.
B. Tried to update Bios to latest version, still no results.
C. Tried reseating them in many ways. a1-b1, a2-b2... almost every possible ways.
D. When I try to boot with only 1 stick, nothing happens, PC starts but nothing works.

Now I want to know if there is anything else I can try before getting myself new ram sticks, or maybe it's my new motherboard that is not working proprely?
Thank you for your help!
 
So, just to clear things up... do both modules work fine on their own, but not together?

If so, try reseating the CPU and make sure you're installing it properly. In the process of doing that you should also check for bent pins on the CPU.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts