Question 100% CPU usage Steam Downloads

Defiantt

Prominent
Apr 18, 2019
9
0
510
0
Whenever I'm downloading steam games, my CPU usage goes to 100%, which is caused by the Steam Bootstrapper Client process from the looks of it.
I'm not entirely sure this is normal? if not, how can I solve this? For testing purposes I tried a download on Epic Games and it seemed pretty steady at 25% with uncapped download speeds.

I did notice If I cap my download speed to 25Mbps on Steam it seems to "solve" it and it sits around 25% when downloading. Uncapped I reach around 110mbps.

Also, I occasionally get short few second system freezes throughout large downloads as well (video, mouse, and audio all stutter for a few seconds). This is with any game launcher, not just Steam. This only seems to happen with my Intel 660P in my system, which I recently just got replaced via RMA thinking it was the initial cause of the freezes.


Specs (nothing overclocked currently):
  • ASRock Z390 Taichi
  • Intel Core i7-8700k
  • Corsair Veng. LPX 16GB
  • EVGA GTX 1080
  • Samsung 860 EVO 500GB (OS)
  • Intel 660P 1TB (Games)
  • Seagate Barracuda 500GB (Storage)
  • EVGA B3 650W
 
Last edited:

Lutfij

Titan
Moderator
How old is the PSU? Also, why would you think that the Intel 660p would be the root of the issue? Latest BIOS update for your motherboard? You might want to also check and see which version of Windows 10 you're currently on.
 

Defiantt

Prominent
Apr 18, 2019
9
0
510
0
How old is the PSU? Also, why would you think that the Intel 660p would be the root of the issue? Latest BIOS update for your motherboard? You might want to also check and see which version of Windows 10 you're currently on.
  1. About 3 years. I've been looking at replacing it with a higher end one, but PSU prices kind of suck right now unfortunately.
  2. The freezing went away when i took it out of my system. I was able to install large games to my 860 EVO without any freezing after taking it out. When I have the 660P in I can't install large games to any storage drive without getting the short freezes, I have no idea why.
  3. Currently on latest bios.
  4. I'm on v1909, and I recently reinstalled windows about 2 weeks ago in hopes of fixing the issue initially.
Not entirely sure the CPU issue and the freezing are related though.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS