Question 1050 Ti not showing a display?

retrac1128

Prominent
Dec 1, 2017
2
0
510
0
Ok so basically the title. I plug my gpu into my motherboard, and turn the pc on. The monitor recognizes that there is an input. It goes from an off state to on, but it is a black screen. No bios, no anything. I don’t know what to do because I can’t see what I’m doing on my screen because there is no display. Thank you for help anyone.
 
It would be much better and easy for us to HELP you, if you can provide FULL PC specs, and more details from your side. Which motherboard is that ? Do you have the latest BIOS version installed on your PC ? Have you tried to clear/reset all the CMOS/BIOS settings to default ?

Please supply the following system details/information:

(Complete System Specs)
-CPU make and model# (clock speed/voltage, type of cooler, and "Core" temperature @ idle and load)
-Motherboard make & model# (include Bios version if graphics card is not recognized or you are having stability issues)
-RAM (amount, clock speed, model#/link of kit, configuration)
-Graphics card(s) make and model# (clock speed, voltage if modified, Driver version and GPU temp both @ idle and load)
-Power supply make,model#, "AND" age (note if using 110V or 220V A/C input)
-HDD/SSD configuration (ie: Raid setup/ back up/ OS drive/etc..)
-Case/Chasis make,model# (fan make, model#, and configuration if having thermal issues)
-Operating System (If using Windows note Framework and service pack version)
-Monitor make, model#, and resolution (If model# is unknown list resolution and refresh rate)

*If the unit is a "laptop" or "All-in-one" system you must note the make and model# of the unit. Be sure you are ALWAYS using the OEM/manufacturer's Driver updates for the unit.

*If "Crashing":
-Note the nature of the "crash" in detail, as there are several definitions for the word "crash".

*If "performance" related issue:
-Note the "exact" point in which the performance reduction occurred (ie: After Windows update, After Bios update, After Driver update, After thermal system shutdown, After Hardware change/upgrade etc...)

*For diagnostic purposes please disable the following:
-Any/all Antivirus/ Anti-malware software
-Any/all OSD monitoring software
-ALL overclocks outside of factory spec
.
 

ASK THE COMMUNITY

TRENDING THREADS