Question 1070 G1 light

Pedro_39

Commendable
Mar 31, 2017
10
0
1,510
0
Hey guys just need a little help here, my 1070 G1 from gigabyte sometimes when i power on my computer doesnt light up the logo only when enter Windows and then sometimes they light up as soon as i Turn on the PC, my question is, is this normal or some malfunction of the gpu? Sorry i Freak out with little things but if u guys could rest my mind i would be gratefull
 
Apr 19, 2019
12
0
10
0
I had the same issue with my gigabyte 1070 ti.
Open your aorus app centre should be in bar on the bottom right with your sound and wifi.
Ensure you have installed RGB Fusion 2.0
This worked for me hope it helps you :)
Let me know how you get on
 

Pedro_39

Commendable
Mar 31, 2017
10
0
1,510
0
Yeah i hav that installed and as soon as i enter the Windows ir works like a charm but sometimes when i Turn on my PC the led from the logo is shut doesnt light until i enter Windows does it happen tou you 2 is that something i should be worried about...
 
Apr 19, 2019
12
0
10
0
Ive always found the gigabyte software to be a bit hit and miss tbh i even uninstalled the rgb fusion for a bit cos it wasnt always consistent! There is nothing wrong with your GPU!!! Its just garbage software. As long as your games run smooth and your temps arent too high then you shouldnt have anything to worry about :) Just enjoy your crisp gaming :p
 
Apr 19, 2019
12
0
10
0
I turned off my PC then turned it back on and the lights flickered a bit then came on a few seconds later just before windows booted up
 

Pedro_39

Commendable
Mar 31, 2017
10
0
1,510
0
Yeah thats what it happens to me they flick then they just light up before getting in Windows but after that is perfectly fine dude thank u some much i was kind of paranoid already xD
 

ASK THE COMMUNITY

TRENDING THREADS