Question 1070 works in one computer but not another?

Jun 13, 2019
4
0
10
0
Bought an ASUS 1070 strix, works in my other machine that already had a 1070 just fine, so it's not the card. The computer in question boots just fine with it's old GTX 660, but will beep once and then no display with the 1070 installed.

The PSU in the problem computer is also brand new and works in my computer.

The problem computer's specs:
PSU: corsair CX750M
MOBO: ASUS m5a97 plus
CPU: amd fx8350
GPU: ASUS gtx1070 ROG strix

Again, this problem computer boots up just fine and I can get into the BIOS with it's previous gtx 660 installed. The strix card works absolutely fine in another computer.

I've tried updating the BIOS on the problem mobo, aside from that I'm at a loss. Any ideas?
 

thomas123321

Honorable
Apr 28, 2013
598
5
11,165
52
Bought an ASUS 1070 strix, works in my other machine that already had a 1070 just fine, so it's not the card. The computer in question boots just fine with it's old GTX 660, but will beep once and then no display with the 1070 installed.

The PSU in the problem computer is also brand new and works in my computer.

The problem computer's specs:
PSU: corsair CX750M
MOBO: ASUS m5a97 plus
CPU: amd fx8350
GPU: ASUS gtx1070 ROG strix

Again, this problem computer boots up just fine and I can get into the BIOS with it's previous gtx 660 installed. The strix card works absolutely fine in another computer.

I've tried updating the BIOS on the problem mobo, aside from that I'm at a loss. Any ideas?
Try removing all nvidia drivers from the computer while the gtx 660 is installed, then switch to the 1070 and check if it boots up without any of the drivers installed.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS