Question 144Hz Monitor stuck at 60Hz

May 26, 2020
1
0
10
0
Hey all. Just got a new 144Hz monitor (Acer ED273) and the UFOTest is saying I'm only getting 60Hz. I've searched to the ends of the internet and none of the solutions are working.

When I go to my display settings, advanced display settings, display adapter properties, monitor, it's selected at 144Hz. I updated my graphics card (AMD Radeon R9 390), updated the drivers on the monitor, updated my Windows version, have it connected with a DisplayPort cable, nothing is working. My roommate upstairs has the exact same monitor running at 144Hz on his PC, I tried his cable and it's still stuck at 60Hz. Tried different browsers. I just don't understand what's going on.

Here's the thing:

I have 2 other montiors connected through DVI that are running at 60Hz each. When I unplugged them, the 144hz was reading at 144hz. When I plugged them back in, it dropped back down to 60hz. To my knowledge, this makes no sense, because one monitor shouldn't dumb down the other.

Any help is appreciated!
 

ASK THE COMMUNITY

TRENDING THREADS