Question 144hz not functioning properly, have to restart every time

Lawrence_30

Commendable
Jul 26, 2017
14
0
1,510
0
Hello,

first of all I want to thank you for wanting to help me out!
This issue has only started recently, and it happens when i first boot up my PC during the day.

I boot my PC and everything seems fine, except not all elements of Windows are in 144hz, for example:
  • My mouse is in 144hz and certain animations
However other elements are not:
  • Moving windows looks choppy and laggy (60hz)
  • any games i boot up are ran at 60hz which is a big difference from the original 144hz.
Any idea why this is happening, and or, how i can fix it?

All ideas are greatly appreciated,
Lawrence
 
Nov 13, 2019
3
0
10
0
First go into the Monitor's Menu, disable
Splendid Demo Mode
AI Light
Then go into NVIDIA Control Panel > Change Resolution
set to the other 1080p option and then set to 144Hz from the Refresh Rate drop down menu there. Also set to RGB and FULL
 

Third-Eye

Distinguished
Jun 26, 2011
536
76
19,090
27
Hello,

first of all I want to thank you for wanting to help me out!
This issue has only started recently, and it happens when i first boot up my PC during the day.

I boot my PC and everything seems fine, except not all elements of Windows are in 144hz, for example:
  • My mouse is in 144hz and certain animations
However other elements are not:
  • Moving windows looks choppy and laggy (60hz)
  • any games i boot up are ran at 60hz which is a big difference from the original 144hz.
Any idea why this is happening, and or, how i can fix it?

All ideas are greatly appreciated,
Lawrence
First of all, what is the model of the monitor? Second, what type of connection are you using connected to the computer and monitor. Third, are you actually setting the monitor to 144Hz or did you just assume it's always set there?
 

Lawrence_30

Commendable
Jul 26, 2017
14
0
1,510
0
It has been set to 144hz for quite some time now, I bought the monitor about 9 months ago, and it was set to 144hz from day 1.
I am using a DVI cable to connect to the monitor!
 

uran6800

Reputable
Apr 26, 2016
80
0
4,640
2
Same is happening to me myabe some new windows updates i dont think is hardware related, at start my minitor goes off just after showing motherbaord logo.
 

Third-Eye

Distinguished
Jun 26, 2011
536
76
19,090
27
The only thing I can think is you are not setting the refresh rate to 144Hz in games and other applications that are full screen, or you did originally but something changed your settings. If it's in windowed mode, it will use the refresh rate of your desktop.
 

ASK THE COMMUNITY

TRENDING THREADS