• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question 1st time build. Pc shows no display. Have troubleshooted.

crispy4u

Commendable
Sep 27, 2017
21
0
1,510
0
Hello,
Specs:
Ryzen 3600x
16 gb 3200 ddr4 vengeance ram
550w evga psu (I probably should have gotten a bigger one)
msi rtx 2060 super gaming 8 gb
Asus x470 prime pro motherboard
also the wraith cooler because the cryorig h7 was not compatible.

I recently built my first pc for gaming and such and it will not post. The computer boots up fine with rgb running on the gpu and motherboard as well as all the fans running. I have re-seated the ram and gpu, and still no display. I don't think I damaged the mob while building (I grounded myself often) or the cpu as it just set in and was not moving. All cables are connected (even the cpu, which some ppl forget for some reason). I then looked on my motherboard box as I bought it last year because Im only 16 so it took some saving up, and it says for 2nd Generation Ryzen CPU's. I then see I have a 3600x.

Is there a way I can update the bios or if that isn't the problem do I need a new motherboard, because on the asus website it says the 3600x is compatible with it. Basically all I'm asking is that is this for sure the problem for why it wont display? Or is there something else. If the mob not being updated is the problem, do I need to go to microcenter or somewhere to get the bios flashed?

Thanks so much!
 

WildCard999

Titan
Moderator
If there's no sticker on the box saying 3rd gen ready then more then likely the issue is with the motherboard BIOS. Microcenter may be able to update the BIOS for you or if your near Massachusetts I could help you out as I have a Ryzen 2600.
 
Reactions: crispy4u

crispy4u

Commendable
Sep 27, 2017
21
0
1,510
0
If there's no sticker on the box saying 3rd gen ready then more then likely the issue is with the motherboard BIOS. Microcenter may be able to update the BIOS for you or if your near Massachusetts I could help you out as I have a Ryzen 2600.
Im hoping it is the bios because I don't know what else it could be, and no unfortunately im in Minnesota. But I'll check in with micro center.
 

WildCard999

Titan
Moderator

ASK THE COMMUNITY

TRENDING THREADS