Question 2 DDR3 8GB rated 1600MHz running low at 800MHz and Dual-Channel isn’t working now

Mar 28, 2021
1
0
10
0
Hello! So I recently purchased two DDR3 8gb rated at 1600MHz each, I put them both in but my computer is only reading them at 800MHz. It says I have the memory capacity of 16GB, but it’s running low at 800MHz instead of 1600MHz. I’d understand it being 800MHz if I was running 2x4gb at 800MHz a piece, but I’m running 2x8gb at 1600MHz. Why is it not running at 1600MHz? Am I doing something wrong or is my logic absolutely incorrect? Also, it will not run Dual-Channel now, it shows both memory slots being used but is running 16gb single not dual. I have them in each other slot like I’ve read, but nothing is working. Please help!!!
Thank you!!
 
Last edited:

kanewolf

Titan
Moderator
Hello! So I recently purchased two DDR3 8gb rated at 1600MHz each, I put them both in but my computer is only reading them at 800MHz. It says I have the memory capacity of 16GB, but it’s running low at 800MHz instead of 1600MHz. I’d understand it being 800MHz if I was running 2x4gb at 800MHz a piece, but I’m running 2x8gb at 1600MHz. Why is it not running at 1600MHz? Am I doing something wrong or is my logic absolutely incorrect? Also, it will not run Dual-Channel now, it shows both memory slots being used but is running 16gb single not dual. I have them in each other slot like I’ve read, but nothing is working. Please help!!!
Thank you!!
It IS running at 1600mhz. The tool shows the clock speed, which has two transfers per clock. That is why it is called double data rate DDR.
 
Reactions: SamirD

ASK THE COMMUNITY

TRENDING THREADS