Question 2 disks dead after a disk crash into a blue screen

Aug 30, 2019
6
0
10
0
So I had a disk crash yesterday where I wasn't able to boot Windows from it. I tried plugging the SSD into a SATA to USB adapter but could not find it in disk management. I also had another disk in my PC with the disk crash (HDD), but didn't check that one before just now. I can not see the HDD either with the SATA to USB adapter. I know the adapter is working, as I've tried it with several other disks on all my different computers, and I can see all my other disks in disk management.

Have I managed to fry both of my drives somehow? This is really weird to me, as I replaced my PSU and the SSD 14 months ago after I had 2 disks crash on me back then. Is there any component in my computer that could have fried them? Last time I was certain it was the PSU's fault as the power cable for a disk caught fire, but since then I have switched out all of the cables inside my computer after I got the new PSU.

I'm really confused about what the issue might be, and I'm now scared it will happen again. I've lost all of my data from my SSD and my HDD now, and I don't want this to happen again. Anything I can do to try and trace what might have gone wrong to fry 2 of my disks? I don't know where to start.
 
maybe the motherboard is faulty

or windows is not recognizing the disks correctly

boot with Ubuntu live on an USB thumb drive and have a look there

try a different PC/laptop with the SATA to USB adapter, if that didn´t hlp
 
Aug 30, 2019
6
0
10
0
maybe the motherboard is faulty

or windows is not recognizing the disks correctly

boot with Ubuntu live on an USB thumb drive and have a look there

try a different PC/laptop with the SATA to USB adapter, if that didn´t hlp
I've tested both disks now on a different computer. The SSD was nowhere to be found in BIOS, but my HDD I could see. A disk check happened, and my HDD is now working. I'm very happy about this, as most of my important data was stored on the HDD. On the SSD I haven't lost much that I won't find on the internet or be able to recreate. It just will take some time. Some of my music was lost, but I've barely started producing so no big deal there either.

I still wonder how my SDD could have died two times in 14 months? I'm considering upgrading my PC now as I don't want this to happen again, but my PC is still very good (i7 4700k and GTX1080). PSU and all cabling is 14 months old so I don't think it's that. Could the mobo really be faulty? Mobo and CPU is almost 7 years old.
 
Aug 30, 2019
6
0
10
0
Low quality PSU can fry HDDs and SSDs, you said you changed PSU but you never specified brand and model.
Changed it to a Corsair RM750x 80 plus gold.

the SATA part of the MB could have been defective while the old PSU was burning
I don't remember if I routed the cabling to SATA differently after changing PSU and cables, but this could be the cause even though it's not very likely is it? Also I have been using the same cable with several SATA connectors on both of the disks. The HDD needed a disk check and worked afterwards, but the SSD is just completely dead and can't see it in BIOS at all, tested in two different computers.
 
which SSD is it?

SSDs are more sensitive when it comes to over current or voltage

Is it recognized in BIOS?
Could be in frozen state
Use the manufacturer´s tool of the SSD and have a look if it´s recognized by it

while the PC is on, unplug sata power cable wait a bit and reconnect the power cable to the SSD
 
Aug 30, 2019
6
0
10
0
which SSD is it?

SSDs are more sensitive when it comes to over current or voltage

Is it recognized in BIOS?
Could be in frozen state
Use the manufacturer´s tool of the SSD and have a look if it´s recognized by it

while the PC is on, unplug sata power cable wait a bit and reconnect the power cable to the SSD
SSD is a Samsung 860 EVO 500GB. Not recognized in BIOS at all. I tried the last method you mentioned on my last disk that failed 14 months ago and it didn't help. I'll try it with this disk as well.
 
Aug 30, 2019
6
0
10
0
which SSD is it?

SSDs are more sensitive when it comes to over current or voltage

Is it recognized in BIOS?
Could be in frozen state
Use the manufacturer´s tool of the SSD and have a look if it´s recognized by it

while the PC is on, unplug sata power cable wait a bit and reconnect the power cable to the SSD
No luck on the power cycle method unfortunately. I have a friend with some enterprise disk recovery software who is going to take a look at my SSD tonight. We'll see if we find anything.

Thanks for the help. Also wanna ask a last question, by the sounds of it, is it more likely to be a faulty mobo / sata port issue? Or do you think the PSU has something to do with it? My HDD had to do a chkdsk so both disks were affected I think but to different degrees I guess.
 
most likely the mobo
"the power cable for a disk caught fire " could have affected the motherboard´s circuits as well or the new psu shutted down more quickly than the other one and the mobo was the culprit from the beginning
 
Aug 30, 2019
6
0
10
0
most likely the mobo
"the power cable for a disk caught fire " could have affected the motherboard´s circuits as well or the new psu shutted down more quickly than the other one and the mobo was the culprit from the beginning
If my old PSU affected my mobo, could the mobo backfire at my new PSU? I'm planning to go hardware shopping this weekend, but don't want to upgrade anything unnecessary like my PSU which is just over a year old.
 

ASK THE COMMUNITY

TRENDING THREADS