Question 2 ethernet connections, local messes up the internet one

Jun 21, 2019
6
0
10
0
Hi, i have a pc at work that has ethernet connection (lets call it N1) to work network, we got locations all over the city so its basically set up just to let us send work emails to each other through outlook. I brought my 3g modem (lets call it N2) to get internet access (it shows as ethernet connection on pc for some reason) and they absolutely refuse to work with each other.
When both are connected it shows as if i have internet access but i guess when i try to use it N1 tries to access internet and fails.
If i disconnect N1, N2 works perfectly, so im just looking for a way to make my pc actually use internet connection instead of trying to run through N1.
 

Traditore

Honorable
On Windows 10, if you have a device with more than one network adapter (such as Ethernet and Wi-Fi), each interface receives a priority value automatically based on its network metric, which defines the primary connection that your device will use to send and receive networking traffic.

Although, for the most part, Windows 10 does a pretty good job selecting an optimal connection to access the network, sometimes you may need to configure the order of the network adapters manually.

If you want to change the order in which Windows 10 uses network adapters, do the following:

  1. Open Settings.
  2. Click on Network & Internet.
  3. Click on Status.
  4. Click the Change Adapter options item.
  5. Right-click the network adapter you want to prioritize (N2), and select Properties.
  6. Select the Internet Protocol Version 4 (TCP/IPv4) item.
  7. Click the Properties button.

  8. In the "General" tab, click the Advanced button.

  9. Clear the Automatic metric option.
  10. In the "Interface metric" field assign a priority value for the adapter.
    The lower metric number means higher priority, so set it to 1.
  11. Click the OK button.
  12. Click the OK button again.
  13. Click the Close button.
Once you've completed the steps, Windows 10 will prioritize the network traffic depending on your configuration.

You also might want to go into your N1 options and set it's metric manually to 5


 
Jun 21, 2019
6
0
10
0
@Traditore, thank you so much for replying!
It worked and i have internet now but it seems that the problem reversed, now Outlook mail cant connect to work server and i cant connect to our SQL server either.

At least i know now how to get internet (and thank you so much you're a lifesaver) but is there perhaps a way to just make the browser use the correct connection so both N1 and N2 could remain functioning?
 
Jun 21, 2019
6
0
10
0
@SkyNetRising sorry its all in russian, i hope its still understandable.

So this is with the metric solution applied: first one is connection N2 (internet)
and second is N1 (work)

I tried using ForceBindIP to start browser using specific connection but it doesnt seem to work
 
Jun 21, 2019
6
0
10
0
@SkyNetRising ah, sorry i misread! russian again, if i can change the language of it let me know.

what should i put in dns then? also, im going home for the day so next update is only on monday.
thank you for helping me so far!
 
From what I can tell the configuration you have tried should have worked. You want the gateway blank on your work network so it uses the one on the 3g network.

What the term "gateway" actually means it is the exit from your network to other networks in this case the internet. You can only have 1 gateway.

The problem with a simple configuration like this is what happens if your work network is actually a bunch of private networks. Say different locations have ip addresses like 172.20.50.x. Your machine has to know to send that network to the router on the 192.20.40.x network rather than attempt to send it to the internet.

What I would do is put it back so it functions on your work network. Leave the 3g network disconnected.

Go into the resource monitor and watch the network tab. You will see all the open connections your machine makes. What you are most interested in is if any of the things you are connecting to are not 172.20.40.x

I will not go into detail but you must put in ROUTE commands for each network when you are running both connections so your machines still knows.

The other issue could be if you company is actually using DNS internally. Most times they look up local servers and then send any request for unknown names to a outside server on the internet and relay the response to you . I have forgotten how to get DNS to work if the company does not use a outside server. If that is your issue maybe someone else knows without me having to relearn this. I know there was some reason just putting 2 dns servers in the list did not solve this type of problem.
 

ASK THE COMMUNITY

TRENDING THREADS