Question 2 Month old RX 6700XT stops displaying when launching games

Oct 3, 2021
2
0
10
0
(Specs will be listed at the bottom)
So I recently purchased an RX 6700xt from AMD and it hasn't been giving me any issues until about 3 weeks ago I also recently purchased a 144hz monitor at the and since then it has also been giving these issues. I was able to run games smoothly in 144hz while I was on driver 21.7.1, but the second I updated to 21.8.1 I was getting these issues I had a feeling it might have been the drivers but I'm not so sure anymore, I also think there could be chances that it is my power supply. As of now, I'm on the latest drivers (21.9.1)
  • RYZEN 7 2700X (MSI 240R AIO)
  • AMD REFERENCE RX 6700XT
  • 16GB 3200MHZ CL16 CORSAIR VENGENCE RGB RAM
  • ASUS TUF B450 PLUS 2 MOTHERBOARD
  • 600W EVGA BRONZE PSU
  • WESTERN DIGITAL SN550 NVME SSD
  • 3TB HDD
  • MSI SEIKRA 110R
 
Hello, it could either be a driver/software and/or a hardware issue. Have you tried to ROLLBACK the GPU drivers, after doing a clean re-install ? I would definitely recommend getting a much better HIGH quality PSU as well. Though, I'm not claiming the current EVGA PSU to be the sole culprit here.

What's the exact Make and Model number of that EVGA PSU ? How Old is it in age ? Which GPU were you using prior to the RX 6700 XT ? What exactly do you mean to say, "stops displaying when launching games" ? Does the system also restart as well while Gaming, or there is an Error message displayed on screen ?

Or the display on the Monitor screen just goes Black, with no input signal as well ? What all PC games have you tried playing on this system ? Are the games TOO graphic demanding ?
 
Oct 3, 2021
2
0
10
0
Hi thank you so replying and helping me out it does mean a lot. No, I have not tried to roll back the drivers but I will tonight. I've had the PSU for about 4 years from an older build I had. Before I purchased my RX 6700xt I had the Msi RX 580 8Gb and have never had any issues whatsoever. What I mean by "stops displaying..." is right when my PC begins to process the game both my displays do not detect the inputs although my computer continues to run in the background I believe my motherboard also stops outputting power as my keyboard and mouse are no longer RGB (they have lost power). Recently about 2 days ago I launched csgo which is probably the least demanding game and it crashed but I began to think it can be the motherboard as my keyboard and mouse disconnect as well. Other games I have tried are rocket league, GTA V, and valorant, all produce the same problem.
 

ASK THE COMMUNITY

TRENDING THREADS