Question 2 Routers Not Playing Nice

Mar 9, 2020
16
0
10
0
First off, I had the exact following setup working flawlessly for years up until a few days ago when I tried to unsuccessfully introduce a network switch into the equation which I have since removed for now. I've now pumped about 5 hours into my current problem and desperately need help fixing it!

Problem:
I'm getting my full 118/11 speed with my ethernet wired desktop hooked up directly into the modem or directly into the [Linksys E2000 Router] that is connected directly to the modem. However, once I turn on my [Asus N66u Router], my WIFI speed wildly fluctuates and my ethernet speed chops down to as low as 10 MBPS download and sometimes doesn't even respond. They definitely seem to be competing with each other.

Setup:
The setup that once worked and that I'm trying to get back to is:
[Cable modem]->[Linksys E2000 Router]->[Asus N66u Router]

The [Cable modem] is plugged into the internet port of the [Linksys E2000 Router] and one of the [Linksys E2000 Router] ethernet ports leads to the internet port of the [Asus N66u Router] just like it was when it was working well a few days ago. My desktop ethernet cord is plugged into the [Linksys E2000 Router].

Sadly, through my network switch introduction attempt, both routers have had their settings reset so I'm not sure what settings I need to change to switch off the apparent congestion in order to get maximum speed on all of my wired and wireless devices. I made sure that the WIFI is disabled on the [Linksys E2000 Router] since I only use the WIFI from the more centrally located [Asus N66u Router]. The Linksys IP is 192.168.1.1 and the Asus IP is 192.168.2.1 so those aren't conflicting.

I also made sure that any QOS or bandwidth control options that I could see on either router are turned off. I've also had to clone the MAC address on the [Asus N66u Router] a few times when on the phone with Asus support so I'm unsure if doing so has messed anything up.
 

alceryes

Distinguished
Setup:
The setup that once worked and that I'm trying to get back to is:
[Cable modem]->[Linksys E2000 Router]->[Asus N66u Router]

The [Cable modem] is plugged into the internet port of the [Linksys E2000 Router] and one of the [Linksys E2000 Router] ethernet ports leads to the internet port of the [Asus N66u Router] just like it was when it was working well a few days ago. My desktop ethernet cord is plugged into the [Linksys E2000 Router].
Sounds like you've got a double NAT going. Although it can work fine if set up properly, double NAT will definitely introduce latency and, on residential-grade routers, can introduce other weird issues. I would plug the E2000 LAN port into one of the LAN ports on the N66u NOT the WAN/internet port.

A couple of questions also need answering. Are you using DHCP? If yes, you should only use it on your E2000. Turn it off on your N66u. I would also turn off wireless on your E2000 unless you need them both on.
Something else to look for is that there are safeguards on many wireless routers (like wireless segmentation) that can mess up WLAN to LAN traffic or don't allow wireless clients to interact with the LAN at all. You will have to adjust these types of settings on both routers to obtain the proper result.

Do you want to use only the N66u for wireless?
Why, specifically, do you have this set up? If you tell us what you are trying to accomplish we'll have a better idea of how to set it up.
 
Reactions: pokerloot

RealBeast

Titan
Moderator
First off, I had the exact following setup working flawlessly for years up until a few days ago when I tried to unsuccessfully introduce a network switch into the equation which I have since removed for now. I've now pumped about 5 hours into my current problem and desperately need help fixing it!

Problem:
I'm getting my full 118/11 speed with my ethernet wired desktop hooked up directly into the modem or directly into the [Linksys E2000 Router] that is connected directly to the modem. However, once I turn on my [Asus N66u Router], my WIFI speed wildly fluctuates and my ethernet speed chops down to as low as 10 MBPS download and sometimes doesn't even respond. They definitely seem to be competing with each other.

Setup:
The setup that once worked and that I'm trying to get back to is:
[Cable modem]->[Linksys E2000 Router]->[Asus N66u Router]

The [Cable modem] is plugged into the internet port of the [Linksys E2000 Router] and one of the [Linksys E2000 Router] ethernet ports leads to the internet port of the [Asus N66u Router] just like it was when it was working well a few days ago. My desktop ethernet cord is plugged into the [Linksys E2000 Router].

Sadly, through my network switch introduction attempt, both routers have had their settings reset so I'm not sure what settings I need to change to switch off the apparent congestion in order to get maximum speed on all of my wired and wireless devices. I made sure that the WIFI is disabled on the [Linksys E2000 Router] since I only use the WIFI from the more centrally located [Asus N66u Router]. The Linksys IP is 192.168.1.1 and the Asus IP is 192.168.2.1 so those aren't conflicting.

I also made sure that any QOS or bandwidth control options that I could see on either router are turned off. I've also had to clone the MAC address on the [Asus N66u Router] a few times when on the phone with Asus support so I'm unsure if doing so has messed anything up.
If you want two distinct subnets, that should work fine if you set the gateway address on the ASUS to the Linksys IP (192.168.1.1).

If you don't need the segmented network, just set the ASUS up as an access point instead -- I have several N56U's set up as APs (plug into LAN port instead of WAN on ASUS, disable DHCP, give ASUS an address in the Linksys network range but outside the Linksys DHCP address block, set security WPA2/AES and same or different SSID and passkey depending on your desires.

Be sure to use distinct 2.4GHz radio frequency on the two selecting from 1, 6, and 11 to avoid interference in either type setup.
 
Reactions: pokerloot
Mar 9, 2020
16
0
10
0
Thanks a ton to responding!

Sounds like you've got a double NAT going. Although it can work fine if set up properly, double NAT will definitely introduce latency and, on residential-grade routers, can introduce other weird issues. I would plug the E2000 LAN port into one of the LAN ports on the N66u NOT the WAN/internet port.
I just went ahead and took the connection from the E2000 out of the N66u's WAN port and put it into one of the LAN ports. I haven't done anything further than that as far as settings but that switch currently took my WIFI down. I can still see the SSIDs but can't get devices to connect to it as of now.

A couple of questions also need answering. Are you using DHCP? If yes, you should only use it on your E2000. Turn it off on your N66u. I would also turn off wireless on your E2000 unless you need them both on.
I do have DHCP on both. I would have to run a MAC address clone on the N66u in order to get WIFI up but have never tried to disable it on the N66u because, well, I'm not entirely certain what it is!

Wireless has been turned off on the E2000 the entire time, I'm only using it to LAN connect a desktop and connecting the N66u to the E2000.

Do you want to use only the N66u for wireless?
Why, specifically, do you have this set up? If you tell us what you are trying to accomplish we'll have a better idea of how to set it up.
Yes, I want to use the N66u only for wireless. My internet cable connects through my basement into my modem. So I put the E2000 down in the basement as well, without wireless, so that I can LAN connect my desktop for peak performance and reliability. I prefer the N66u in a more central location to get wider coverage so I moved the N66u up to a first floor centralized closet and have seen much better WIFI coverage.

The way I had stero equipment set up in my house prior to this, there was a pathway from the basement up to that closet so I easily hardlined the N66u to the basement's E2000. However, there's no real way for me to LAN connect my desktop to the N66u aside from drilling some holes and having more exposed cables.
 
Mar 9, 2020
16
0
10
0
If you want two distinct subnets, that should work fine if you set the gateway address on the ASUS to the Linksys IP (192.168.1.1).

If you don't need the segmented network, just set the ASUS up as an access point instead -- I have several N56U's set up as APs (plug into LAN port instead of WAN on ASUS, disable DHCP, give ASUS an address in the Linksys network range but outside the Linksys DHCP address block, set security WPA2/AES and same or different SSID and passkey depending on your desires.

Be sure to use distinct 2.4GHz radio frequency on the two selecting from 1, 6, and 11 to avoid interference in either type setup.
A big thanks to you as well for trying to help me out, much appreciated guys!

I don't believe I need a segmented network but I'm absolutely a novice at this aside from what I've learned on my own. I replied with this to the other poster first but I just want the N66u to use wireless and it's ideal for me to LAN connect my desktop into the E2000. If this coincides with turning the N66u into an access point then I'm all for it.

I think I can manage to make all the changes you mentioned if you think this is the best approach to suit my needs but this part is tripping me up a bit:

give ASUS an address in the Linksys network range but outside the Linksys DHCP address block, set security WPA2/AES and same or different SSID and passkey depending on your desires.

Be sure to use distinct 2.4GHz radio frequency on the two selecting from 1, 6, and 11 to avoid interference in either type setup.
Just to clarify, I have disabled and don't intend to renable the wireless on my E2000. Would this part still pertain to my situation? If so, I have no idea how to calculate the range part.
 

alceryes

Distinguished
Cool. Your explanation of the setup makes sense.

You need to reboot your devices (including your modem) when switching ports. Devices remember what they were connected to and may times have a hard time letting go. ;) Configure properly, unplug all, plug in from outside in (modem -> E2000 -> N66u) waiting 5 mins in between.

So you should have the cable modem plugged in to the WAN port on the E2000 and a LAN port on the E2000 plugged into one of the LAN ports on the N66u. Wireless is off on the E2000 and is on on the N66u. DHCP is off on the N66u and on on the E2000. @RealBeast was asking you to assign a static IP to the N66u that is within the same subnet of the E2000 but outside of it's DHCP scope.

I'm assuming that your are using defaults as much as possible so it would be something like this -
IP settings of E2000 - 192.168.1.1 255.255.255.0
DHCP range on E2000 - 192.168.1.100 - 192.168.1.254 (if you plan on having more than 154 devices connected, at the same time, this range won't be sufficient)
IP of N66u - 192.168.1.2 255.255.255.0 (notice that it's NOT in the 100-254 that is your DHCP range)

Apart from this you'll need to turn off/adjust some other settings, like ones that can interfere with WLAN communicating with the LAN and vice versa.
 
Reactions: pokerloot

RealBeast

Titan
Moderator
Cool. Your explanation of the setup makes sense.

You need to reboot your devices (including your modem) when switching ports. Devices remember what they were connected to and may times have a hard time letting go. ;) Configure properly, unplug all, plug in from outside in (modem -> E2000 -> N66u) waiting 5 mins in between.

So you should have the cable modem plugged in to the WAN port on the E2000 and a LAN port on the E2000 plugged into one of the LAN ports on the N66u. Wireless is off on the E2000 and is on on the N66u. DHCP is off on the N66u and on on the E2000. @RealBeast was asking you to assign a static IP to the N66u that is within the same subnet of the E2000 but outside of it's DHCP scope.

I'm assuming that your are using defaults as much as possible so it would be something like this -
IP settings of E2000 - 192.168.1.1 255.255.255.0
DHCP range on E2000 - 192.168.1.100 - 192.168.1.254 (if you plan on having more than 154 devices connected, at the same time, this range won't be sufficient)
IP of N66u - 192.168.1.2 255.255.255.0 (notice that it's NOT in the 100-254 that is your DHCP range)

Apart from this you'll need to turn off/adjust some other settings, like ones that can interfere with WLAN communicating with the LAN and vice versa.
Yes, that will work fine and that router would melt if it had 150 devices attached to route. ;) And while the subnet mask with be /24 (i.e. 255.255.255.0) you shouldn't have to set it, it should be the default.

And your wireless can be off on any of the network devices, so yes the E2000 wireless can be off if you like. The only issue is if you have it on, you do not want it to interfere by having the same or an overlapping 2.4GHz channel.
 
Reactions: pokerloot
Mar 9, 2020
16
0
10
0
Thanks guys I will give this setup a go right now and report back.

I'm assuming that your are using defaults as much as possible so it would be something like this -
IP settings of E2000 - 192.168.1.1 255.255.255.0
DHCP range on E2000 - 192.168.1.100 - 192.168.1.254 (if you plan on having more than 154 devices connected, at the same time, this range won't be sufficient)
IP of N66u - 192.168.1.2 255.255.255.0 (notice that it's NOT in the 100-254 that is your DHCP range)
So my E2000 is indeed the default 192.168.1.1 255.255.255.0

The N66u, when set up after the E2000, saw the IP conflict and changed it's IP to 192.168.2.1 255.255.255.0 (not 192.168.1.2). How does this minor difference change the DHCP range and anything I should change within the DHCP settings?
 

alceryes

Distinguished
This 'minor' change is a 'major' one. The N66u is now not on the same network as the E2000.
You should change it to the IP I listed above. The N66u is probably trying to be 192.168.1.1, thus the IP conflict. Keep the DHCP range on the E2000 as listed above and remember to DISABLE DHCP on the N66u.
If need be, assign a static IP to your computer and plug directly into the N66u LAN (without it being on the network with the E2000), and configure the N66u properly.
 
Reactions: pokerloot
Mar 9, 2020
16
0
10
0
This 'minor' change is a 'major' one. The N66u is now not on the same network as the E2000.
You should change it to the IP I listed above. The N66u is probably trying to be 192.168.1.1, thus the IP conflict. Keep the DHCP range on the E2000 as listed above and remember to DISABLE DHCP on the N66u.
If need be, assign a static IP to your computer and plug directly into the N66u LAN (without it being on the network with the E2000), and configure the N66u properly.
Ok I see what you're saying but having a bit of difficulty executing it. I have made sure that my wireless is completely off on the E2000. Here is the E2000's IP address and range (I left the user # at it's default 50, hope that's ok):



My (hopefully) last problem I'm having is turning the DHCP off on the N66u and, what I think I'm gathering, is changing the IP address as well as assigning it a static IP address.

When I go to the LAN IP of the N66u and attempt to apply the change of changing it from '192.168.2.1' to '192.168.1.2' with subnet mask remaining the same at 255.255.255.0 I get an error "WAN and LAN should have different IP address and subnet".

I went into the LAN-> DHCP Server within the N66u and change 'Enable the DHCP Server' to 'No', it seems to kick me out with no way of getting back into the menu without a reset that I could find. So I believe I have to change the static IP stuff before turning off the DHCP which you both might have mentioned.

This is where I'm most confused.

Under LAN-> DHCP Server, there's a 'IP Pool Starting Address' and 'Ending Address' that you both were referring to as well as a 'Default Gateway' section (should I mess with this?). Also, under WAN, thereis a way to change the WAN Connection type to static and input an IP Address, Subnet Mask, and Gateway there.

Sorry for still not fully understanding everything but after getting locked out from turning off the DHCP prematurely before, I'm unsure of the exact order to do things from this point and also what to put exactly in the fields mentioned above.
 

alceryes

Distinguished
Let's plug the computer directly into the LAN side of the N66u.

If the N66u is still on 192.168.2.1 we need to set a static IP on the computer that's connected to it. Something like 192.168.2.77 255.255.255.0 should work fine. With this setting you should be able to access the N66u and configure it.

Note, when you change the IP of the N66u you'll need to change the static IP on your computer in order to access it again. So, if you properly change the N66u to be 192.168.1.2 you'll then need to change your computer to be on the same network (e.g. 192.168.1.77). Some router properly forward you to the new IP, many don't. Also, there's nothing special with the '77' I picked. It's just a random number within the range that I hope isn't being used.

Remember to go through the reboot steps I listed above once you think you've got everything set up properly.

Edit - No need to touch any static WAN settings. I'm pretty sure you're using a standard 'dynamic' connection from your cable company. What is the default setting for the default gateway in DHCP on your E2000? Is it just the E2000 address (192.168.1.1)?

Welcome to the world of networking! :p
 
Last edited:
Reactions: pokerloot
Mar 9, 2020
16
0
10
0
Let's plug the computer directly into the LAN side of the N66u.

If the N66u is still on 192.168.2.1 we need to set a static IP on the computer that's connected to it. Something like 192.168.2.77 255.255.255.0 should work fine. With this setting you should be able to access the N66u and configure it.

Note, when you change the IP of the N66u you'll need to change the static IP on your computer in order to access it again. So, if you properly change the N66u to be 192.168.1.2 you'll then need to change your computer to be on the same network (e.g. 192.168.1.77). Some router properly forward you to the new IP, many don't. Also, there's nothing special with the '77' I picked. It's just a random number within the range that I hope isn't being used.

Remember to go through the reboot steps I listed above once you think you've got everything set up properly.

Edit - No need to touch any static WAN settings. I'm pretty sure you're using a standard 'dynamic' connection from your cable company. What is the default setting for the default gateway in DHCP on your E2000? Is it just the E2000 address (192.168.1.1)?

Welcome to the world of networking! :p
Thanks for being very patient with me.

Ok I think with all the help we're almost there. I believe I followed all of your steps but after rebooting everything, I couldn't get wireless or LAN internet anywhere and even connecting directly to the modem didn't get internet. I'm not sure if I was supposed to do this but I then changed my computer's IP from the 192.168.1.77 to auto and restarted everything, including the PC, again and connections are up for the moment. Should I leave this as is or change it back to something?

I now have wireless and LAN internet going properly with the N66u connected LAN to the E2000's LAN. I'm getting full down/up speeds of 118/12 for the PC. Oddly, my phone via WIFI is getting 55/22 and I've never ever seen an upload anywhere close to that so it's quite odd.

In your example earlier of "
DHCP range on E2000 - 192.168.1.100 - 192.168.1.254 (if you plan on having more than 154 devices connected, at the same time, this range won't be sufficient)
IP of N66u - 192.168.1.2 255.255.255.0 (notice that it's NOT in the 100-254 that is your DHCP range) "

I concede I'm definitely reading that wrong since I thought the N66u's 192.168.1.2 = 192.168.1.200 which would indeed fall into the DCHP range of 192.168.1.100-254. So could you check over my current settings provided below to make sure that stuff looks ok?

Here are my pool addresses which I'm unsure if they are close enough and assigned properly:

E2000:


N66u:


Anything conflicting there? Note that the N66u IP was successfully changed to 192.168.1.2!

"What is the default setting for the default gateway in DHCP on your E2000? Is it just the E2000 address (192.168.1.1)? "

Under 'Internet Connection' on the E2000, it shows a default gateway of
74.65.0.1. Should I be putting this value as the default gateway of the N66u as well?

Edit: My phone wireless speeds are now coming back as max as well which is awesome! But please let me know if I need to make any of those proposed changes to make sure nothing goes wrong in the future!

 
Last edited:

alceryes

Distinguished
Sorry, I should've mentioned that, once you get everything set the way it should be, you should go back to auto (DHCP) on your computer.

If everything is working as you'd like, I think we're good. For the DG on the E2000, I was just curious. Looks like it's listing the next hop as your DG, which is fine.
 
Reactions: pokerloot
Mar 9, 2020
16
0
10
0
Sorry, I should've mentioned that, once you get everything set the way it should be, you should go back to auto (DHCP) on your computer.

If everything is working as you'd like, I think we're good. For the DG on the E2000, I was just curious. Looks like it's listing the next hop as your DG, which is fine.
Cheers thank you and RealBeast so very much for taking the time to help me sort everything out. You not only fixed my problem but taught me a lot in the process which I hope to pay forward some day without screwing anyone up!

Take care and thanks again!
 

ASK THE COMMUNITY

TRENDING THREADS