Question 2009 Mac Pro & RX 580

Mar 5, 2019
2
0
10
0
Hi, I hope this is in the correct forum and thanks in advance for any help. I have a 2009 Mac Pro -> 5,1 and upgraded CPUs (Xeon 5680) running OS X 10.13.6. I wanted to upgrade my video card. I have tried the Vega 56 and now the Sapphire Nitro RX 580. Using both Aux power ports. These were my results:

When I tried the Vega, it booted fine, BUT NO VIDEO. Thinking it may be a bad card I returned for a replacement and am waiting on that. Resigned to save for a PC build.

So I then purchased the Sapphire Nitro+ RX 580 (nice blue card)! When I installed the card I get nothing. Just a click from the PSU and that’s it.

So I put my stock GT 120 card back in and everything is fine. Boots just fine. I tried the RX 580 again in the other x16 slot. “Click” was all I got. GT 120 back in boots fine.

I almost think it is a PSU issue; that maybe it is not putting out the power needed. The voltages on the aux ports is fine, but I have no way to test with a calibrated load to see if indeed the PSU is putting out the power it is supposed to.

Any thoughts? Am I doing something wrong or forget to do something? I have been asking this question all over the web but no one seems to have an idea.

-Mark
 

ASK THE COMMUNITY