Question 2070 super no signal

May 8, 2021
1
0
10
0
Strange issue that has been eluding me now for 4 hours, pc was running fine and decided to restart it as it had been on for a few days. Windows shuts down but doesnt come back on, everything has power all leds on and fan spinning but monitors showing no signal.
So far i have tried to swap the ram slots, tried individual sticks of ram in each slot, reset the cmos, checked all power connections and are fine, tried booting with no peripherals connected, tried with different monitors and different cables all of which hasnt worked.

Only thing that has worked so far is that i swapped the Asus 2070 super out for my old msi 970 and it immediately booted up with display on both monitors. Tried the 2070 in my old pc that the 970 came out of and it works fine and displays have signal but when i put the 2070 back into the current pc i have no signal. Any help is much appreciated.

My specs are:
AMD Ryzen 7 2700X Eight-Core Processor with stock cooler
2x8gb corsair vengeance lpx 3200mhz
Gigabyte B450M DS3H-CF (AM4) bios version f50
ASUS Turbo RTX 2070 SUPER EVO
650w psu
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

650W is the wattage of the PSU. We're going to need the make and model of the unit. Include the age of the unit if it's been used a while. The rams should be in slots A2 and B2. Update your BISO from F50 in the following manner, F51>F52>F60>F61a.

I'd also ask you to source a donor PSU for your build that is reliably built from your neighbor or friend.
 

ASK THE COMMUNITY

TRENDING THREADS