• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question 2080 Ti and PSU problems?

Jun 24, 2020
2
0
10
0
2080 Ti and PSU Problems

So I recently bought a 2080 Ti from a secondhand platform but the card was not used once since it was a warranty exchange card (meaning the original one was sent in and he got a replacement) anyways.
I placed the card in my system, where it seemed like the card was broken, in the beginning i ran some various stress tester (furmark and combustor) nothing, started a in game benchmark —> Artifacting, freez and the followed by a crash. And after that it acted all weird. So I let him know we sent the card back to the manufacturer and I got it back and still got the same problems. I sent him that card back and it worked fine in his system with high overclocking settings and that for 3hrs.

So I dont know what the problem is, i have heard there are 2080 Ti problems with PSU. But can anyone help me ?

My setup:
  • AMD Ryzen 9 3900X
  • Corsair Vengance RGB Pro 16GB
  • Gigabyte X570 Aorus Elite
  • Seasonic Focus GX-850
  • (I am using custom cables by CableMod)
Link for videos: https://mega.nz/folder/lAgDwZZB
 
Last edited:
Jun 24, 2020
2
0
10
0
You could check the voltages with HWINfo.
The main ones are +12, +5 and + 3.3.
You want them within 5% both at idle and under heavy load.
RIP

I already sent it back to him, he tested it in his system with no problems...
Like u can see in the files.

As soon as i get it back I check ! Could it be faulty cables ?
 

ASK THE COMMUNITY

TRENDING THREADS