Question 2080TI Ryzen 3700X Low FPS

Dec 6, 2019
19
1
15
0
Hey guys, need help with my new build. Currently playing Monster Hunter on Highest settings and the new HD texture pack. And my FPS hits around 45 to 55. I've been looking at benchmarks and some people get well over 100. I dont know whats happening. Ive tried uninstalling my GPU drivers and reinstalling tried resetting my windows installation. Nothing happens. Need some help please.
 
Dec 6, 2019
19
1
15
0
Full system specs?

Not a fresh windows install, just a reset on windows that puts it to default and uninstalls all apps except windows. Haven't tried a full fresh windows install. As for full system specs.

GPU: Asus RTX 2080Ti Dual OC.
CPU: AMD Ryzen 7 3700X
MOBO: MSI MPG X570 Gaming Plus
RAM: Corsair Vengeance DDR4 3600MHZ (A-XMP on)
PSU: Corsair HX1000 switched to multiple +12v
Cooling: Corsair Hydro X custom Loop.
 
Dec 6, 2019
19
1
15
0
Make and mode of PSU?
Sorry, but I don't understand what you mean by this. The make of the PSU is Corsair HX1000. And I don't know If it has multiple modes or whatever.

Was the windows install from a different PC?
The windows install was fresh from a USB install from RUFUS.
 
Dec 6, 2019
19
1
15
0
Whoa, that gpu score...

In one of your earlier posts, you did mention a Corsair Hydro X custom loop. The gpu is part of said loop? Perhaps part of the waterblock isn't making proper contact.
I did have an issue with the GPU block when I first built the PC. Temps would instantly rise to 80'C degrees ,so I re-seated the block and added new thermal paste and it fixed the problem. Game I was playing then was Call Of Duty Modern Warfare (2018). And having done that haven't had any issues with it. But monster hunter is the only game I can't get even 60FPS on.

I should mention I was also having a problem with CSGO. FPS counter was showing I had 150FPS which is lower than what my 2080Ti should be giving. But the gameplay was noticeably stuttery, and performing really bad. But earlier I did a fresh install of windows with rufus, completely wiped my C drive, and uninstalled my GPU driver with DDU in safe mod. That fixed CSGO for me, now i'm at 200-300FPS and game is very smooth. So I'm kind of thinking with the new Monster Hunter ICEBORNE expansion. The devs might've not really optimized it. But some people are getting well over 100 frames.
 

zx128k

Upstanding
Nov 23, 2019
390
79
270
4
Does the OP have all the power connectors attached to the GPU? Are all the power connectors on the one PCIe cable going back to the PSU or two different PCIe cables going back to the gpu?
 
Reactions: Ainzz
Dec 6, 2019
19
1
15
0
Does the OP have all the power connectors attached to the GPU? Are all the power connectors on the one PCIe cable going back to the PSU or two different PCIe cables going back to the gpu?
I have 2 seperate PCIE cables plugged into GPU as I heard that's the best way to give it power for best performance
 
Dec 6, 2019
19
1
15
0
I'd take a look at that GPU and make sure everything is making proper contact. You may be getting throttling on the VRAM or the VRM on GPU.
Yeah I'll do that once I get a drain for my custom loop, I think I might get a replacement CPU block because MHW is a CPU intensive game and the utilization hits tops of 30-60% and my friend is getting from 70-90% utilization. And he gets better frames. But he's on intel.
 

ASK THE COMMUNITY

TRENDING THREADS