2400 MHz RAM capped at 1600 MHz on MSI Motherboard (capable of 2400)

mcl99

Prominent
Aug 16, 2017
6
0
510
0
I recently decided to upgrade ram to 2x8Gb Corsair Vengeance Pro 2400 MHz from 2x4Gb Crucial Ballistic, yet when I'm in my BIOS, the maximum frequency I can select is 1600 MHz despite support for up to 2400MH (on 22nm CPU chips which I have).
B75MA-P45 MSI Motherboard
Intel i5 3570k 3.4GHz CPU
Corsair 2x8Gb 2400MH RAM

Something to note is in the BIOS, it identifies the ram properly at 2400MHz and is able to properly detect the timings, it just automatically adjusts the frequency down. The BIOS version is 1.9 which should be the most up to date.
 
Look at it with CPUz. I have DDR3-2800 RAM and it is set in the BIOS as that.



This shows the actual speed which is 1400 MHz. DDR = double data rate so you take the actual and multiply by 2 to get the effective speed (which is 2800 in my case). Does your motherboard support XMP profiles? If so you should be able to just enable XMP and it should automatically set it to the proper settings.

1600 MHz would be DDR3-3200 RAM.
 

mcl99

Prominent
Aug 16, 2017
6
0
510
0


CPUZ showing incorrect frequency and timings

Still reading wrong and also with different timings than set in the BIOS. I have enabled XMP which shows the proper timings as well but still does not adjust the frequency.
 

mcl99

Prominent
Aug 16, 2017
6
0
510
0


I see "DDR3 1066/1333,1600*/1800*/2000*/2200*/2400*(OC, 22nm CPU required)" on the site which is the same link you sent me as well.
 


I was going to bring that up as well but you beat me to it. Can you enable XMP? does it have that option?


actually i think rgd1101 figured it out. However it raises the question, why is it listed if it is impossible?
 

mcl99

Prominent
Aug 16, 2017
6
0
510
0


Here (I was having issues with screenshot saving to USB so sorry you have to deal with phone pics) are the settings from my BIOS.

OC Settings with XMP Enabled

Pic of other settings just in case
 

mcl99

Prominent
Aug 16, 2017
6
0
510
0


So this means it is impossible to push past 1600MHz and correct the timings?
 

mcl99

Prominent
Aug 16, 2017
6
0
510
0


No, im still showing the same settings as I did in the first image I linked :(

Do you think it is necessary to M-Flash again? My ME seems out of date. I am showing 8.0.XXXX and I think it should be 8.1.XXXX.
 

Similar threads


TRENDING THREADS