[SOLVED] 2600X Stock voltage too high Fatal1ty B450 Gaming K4

DSD27

Honorable
Jun 27, 2013
12
0
10,520
1
Hi,
I have a 2600X with a Fatal1ty B450 Gaming K4, with everything at stock/default, the Vcore goes up to 1.48v when browsing and gaming, which I know isn't exactly safe...
When I try to set a manual Vcore it is impossible, it only has a "VID" setting, the default VID is 1.18750v and lowering that value won't change or affect anything!
I have the most recent Bios, maybe that's the problem? Because I've seen on youtube older videos of this motherboard with a Vcore setting. Also under "performance boost" I only have this choices: Auto; Cinebench R15; Cinebench R11 and Geekbench. No explanation whatsoever about what they do... :heink:
How can a B450 motheboard not have a manual Vcore setting?
 

DSD27

Honorable
Jun 27, 2013
12
0
10,520
1
I found the solution. I disabled "core performance boost" in the bios, which disables that horrible XFR. Now the voltage stays true to that VID value I input, doesn't go up in spikes anymore! I don't understand why anyone would use XFR, it's complete garbage with those INSANELY high volatges, maybe AMD's idea is: if we kill the CPU we will buy a new one therefore give them more money?
 

DSD27

Honorable
Jun 27, 2013
12
0
10,520
1
I found the solution. I disabled "core performance boost" in the bios, which disables that horrible XFR. Now the voltage stays true to that VID value I input, doesn't go up in spikes anymore! I don't understand why anyone would use XFR, it's complete garbage with those INSANELY high volatges, maybe AMD's idea is: if we kill the CPU we will buy a new one therefore give them more money?
 

ASK THE COMMUNITY

TRENDING THREADS