[SOLVED] 2nd GPU installation attempt

kurdtnz

Notable
Feb 24, 2020
927
135
1,090
20
Ryzen 5 3400G
Sapphire Pulse RX570
2x8GB Corsair Vengeance LPX RAM
Corsair CX500 PSU
Adata 500GB M.2, (boot drive)
500GB SSD storage drive
X570 i aorus pro wifi

After a failed 1st attempt at installing the GPU a few days ago,I re-installed it this morning. I followed the clean install tutorial on this page and thought everything was finally working ok. Ive been able to use the PC with no issues, go online, watch netflix etc however,im experiencing a weird issue. Sometimes if i click on the windows icon on the bottom left to put the PC asleep,or turn it off etc or sometimes when I click on something on my task bar, eg, the AMD Radeon Software icon, my monitor will go black for a couple of seconds before switching back on again,it may do this a couple of times and then starts working fine again. Anyone know what is causing this?
 

STcreature

Honorable
Nov 12, 2014
123
1
10,715
8
Ive tried 2 different HDMI cables but it still does it, think it's definitely something to do with the GPU or software? Im not really a gamer so it's not like im pushing the GPU either. It works fine when Im doing anything else, web brousing,watching twitch,netflix etc, only happening when I try and click on another programme,(like the amd radeon software but not everytime,) and when i sometimes click the windows icon.
hmm interesting
i doubt its a Graphics card problem i want you to do this next : If you have done this in the clean installation guide let me know , otherwise

Click Windows icon + X on your keyboard > choose device manager > and then over at display adapters right click your display driver and either uninstall it (dont worry your CPU has integrated graphics) or Roll back the driver by going to properties > driver > and then hitting rollback
Then click here and download your Graphics card driver again

*) also its worth a shout to try your monitor on a different computer see if it occurs
 
Last edited:

kurdtnz

Notable
Feb 24, 2020
927
135
1,090
20
Does it only occur when clicking on certain applications or does it just happen randomly
It was happening when I clicked on the 'AMD Radeon Software' icon but that seems to have stopped but it happens mainly when i click on the windows icon to either switch it off or go into settings etc. when i click on it, the menu pops up then the screen will freeze for a few seconds, then the screen goes black, then it switches back on,(it may do this cycle once or 2-3 times,) then it works fine.
 

STcreature

Honorable
Nov 12, 2014
123
1
10,715
8
What are you using to connect your gpu to your monitor it could be a faulty cable or even a faulty gpu output plug
Try using a different cable on a different port see if the problem stops

theres a number of reasons this can occur try to eliminate the possibility of problems in video output first
 
Reactions: kurdtnz

kurdtnz

Notable
Feb 24, 2020
927
135
1,090
20
Ive tried 2 different HDMI cables but it still does it, think it's definitely something to do with the GPU or software? Im not really a gamer so it's not like im pushing the GPU either. It works fine when Im doing anything else, web brousing,watching twitch,netflix etc, only happening when I try and click on another programme,(like the amd radeon software but not everytime,) and when i sometimes click the windows icon.
 

STcreature

Honorable
Nov 12, 2014
123
1
10,715
8
Ive tried 2 different HDMI cables but it still does it, think it's definitely something to do with the GPU or software? Im not really a gamer so it's not like im pushing the GPU either. It works fine when Im doing anything else, web brousing,watching twitch,netflix etc, only happening when I try and click on another programme,(like the amd radeon software but not everytime,) and when i sometimes click the windows icon.
hmm interesting
i doubt its a Graphics card problem i want you to do this next : If you have done this in the clean installation guide let me know , otherwise

Click Windows icon + X on your keyboard > choose device manager > and then over at display adapters right click your display driver and either uninstall it (dont worry your CPU has integrated graphics) or Roll back the driver by going to properties > driver > and then hitting rollback
Then click here and download your Graphics card driver again

*) also its worth a shout to try your monitor on a different computer see if it occurs
 
Last edited:

kurdtnz

Notable
Feb 24, 2020
927
135
1,090
20
To be brutally honest,ive totally given up with the GPU......I tried to do a clean install of the drivers and it did not go well at all. I followed the clean installation guide like the first time,i went into safe mode, uninstalled the drivers and then tried to upload the new driver i had stored on my pc, it started installing ok then just went BSOD. I left it for awhile but the screen just wouldnt switch back on so i reset my pc and then it just got stuck in a loop. It would try to auto fix, then whenever i tried to go back into safe mode,(or try anything else for that matter,) it wouldnt let me and just go back into auto repair every single time the pc restarted and i couldnt do anything. So Ive taken the GPU out and reinstalled the drivers with my Ryzen 5 3400g and everything is now working fine. I would of liked to run my system with a GPU but alas, think i must be allergic to GPU's or something. Thanks for your help anyway.
 

ASK THE COMMUNITY

TRENDING THREADS