[SOLVED] 2nd m.2 ssd not found on b450-i motherboard

Dec 8, 2019
20
0
10
0
I just recently finished building my gaming pc not even a week ago, and i had installed everything properly. I booted it up, and went into the BIOS to see if everything was there. But when I was about to install windows, I realized only one of my 2 m.2 ssd's were appearing. I proceeded to install windows on the main drive in hope that I would find a solution soon enough.
My specs are ---

CPU: Ryzen 2 2700x

GPU: MSI Gaming Z RTX 2060

RAM:G.Skill Trident z 2 x 8 @ 3600

MOBO:Asus ROG Strix B450- i Gaming

PSU: Corsair RM(2019) 80+ gold 850w (overkill)

the one ssd out of the 2 that is supposedly failing is the Crucial Mx500 250gb m.2 ssd
 

Lutfij

Titan
Moderator
Check and see which BIOS version you'r currently on for your motherboard. If you have updates pending, manually update the BIOS to the latest. Can you list both makes and models of the SSD's on your system and which slots they occupy on the board? A link to each would help two fold.
 
Dec 8, 2019
20
0
10
0
Check and see which BIOS version you'r currently on for your motherboard. If you have updates pending, manually update the BIOS to the latest. Can you list both makes and models of the SSD's on your system and which slots they occupy on the board? A link to each would help two fold.
the other ssd is https://www.newegg.com/crucial-p1-1tb/p/N82E16820156199


and the failing one is the https://www.newegg.com/crucial-mx500-250gb/p/N82E16820156176

i did try to update the bios once but when i had it installed on a usb and went to the tab to flash the bios with it, i wasnt sure where to select the update file.
 
Last edited by a moderator:
Dec 8, 2019
20
0
10
0
by doing that wouldnt it effect the temps a little bit causing it to get a bit warmer, therefore slowing it down due to high temps because the front one has the heat spreader with thermal pads.
 

USAFRet

Titan
Moderator
Mar 16, 2013
117,214
2,624
148,290
19,099
by doing that wouldnt it effect the temps a little bit causing it to get a bit warmer, therefore slowing it down due to high temps because the front one has the heat spreader with thermal pads.
Temps are irrelevant if the slots don't support the drives in question.

There is only one possible configuration for that motherboard and those drives.
 
Dec 8, 2019
20
0
10
0
Did you read manual of your motherboard?
Only one M.2 slot on your board supports sata M.2 drives (frontal one M2_1).

You have to install MX500 in M2_1 slot,
install Cucial P1 in second slot M2_2.
i also did what you said to do and i swapped the slots that they were in and the P1 i still the only drive that shows up
 
Dec 8, 2019
20
0
10
0
It appears that the ssd is there but it doesnt show up as a drive in the BIOS under the boot tab, and yes AHCI is enabled

And i can confirm that the MX500 is on the front (cpu side), and the P1 is on the back
 
Last edited:
Windows OS files are located in
\Windows\​
\Program Files\​
\Program Files (x86)\​
\Program Data\​

User profiles are in
\Users\​

Delete those folders/files and windows is gone. But it's not so easy to delete them. You'll have to take ownership of those folders/files, reset file access permissions. BTW - deleting is not possible, if active windows is running from those locations. Active windows lives in C: , secondary windows location will have a different drive letter.
 
Dec 8, 2019
20
0
10
0
Windows OS files are located in
\Windows\​
\Program Files\​
\Program Files (x86)\​
\Program Data\​

User profiles are in
\Users\​

Delete those folders/files and windows is gone. But it's not so easy to delete them. You'll have to take ownership of those folders/files, reset file access permissions. BTW - deleting is not possible, if active windows is running from those locations. Active windows lives in C: , secondary windows location will have a different drive letter.
So my plan is

to remove the 1tb drive

download a new copy of windows onto the MX500 250gb, and set it as the first boot option,

plug the 1tb drive back in and delete the old copy of windows and it should be fine after i get through all that, correct?
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts