Question 2x less FPS with GTX1080

May 13, 2019
9
0
10
0
Hello everyone!
I recently get my self GTX1080 Armor OC from MSI and im experiencing twice as low FPS than i see in lots of differend benchmarks on youtube or benchmark sites.

My iron: View: https://imgur.com/a/wp7s5BQ

-i7 4790k (Turbo Boost on all cores ON, 4.5GHz)
-GTX1080 MSI Armor OC (1905MHz when fully loaded, 5005MHz memory clock)
-HyperX Savage 16GB 1600Mhz (2x 4GB 1600MHz, 1x 8GB 1866MHz locked at 1600MHz)
-MSI Z97S SLI Krait Edition MBO
-Fortron HyperM 500W PSU
-Kraken X41
-SSHD WD2 Black [120GB ssd (Windows only on SSD part of SSHD), 1T HDD (games and programs only on HDD part of SSHD)]
-Acer GN246HL (1080p, 144HZ)

Ive tried GTA V, R6: Siege, The Division 2, AC: Unity, PUBG and in all of these games i set settings exacly like in benchmark videos but never got close to results that are in videos. For example, GTA V, multiple people had 114-120FPS on ultra with exacly same HW as i have, but i got 2x as bad FPS, exacly my FPS is around 54-62 with exacly same settings like in videos. Same goes for The Division 2 where i saw in benchmarks, that people have 85-100FPS on ultra preset when again, i have twice as low FPS hovering around 70FPS, but dropping to 50-60 when outdors in highly occupied locations. In R6: Siege im experiencing better results where i have 100-120FPS on Ultra, BUT, in benchmarks i saw people having 190-220FPS on Ultra, and i will not go into detail with PUBG where i have 60-70 fps on Ultra with alot stutter. Keep in mind that i always set exacly same settings as people in benchmarks.

My CPU is mostly running at 60-80% usage, depend on games CPU utilization (60°C max. when 90% load). My GPU is mostly running at 90-98% usage, depend on games GPU utilization (73°C max. when 98-100% load).

I have just recently fresh installed Windows 10 with everything set to MAX. performance. All drivers updated through Driver Booster and GPU drivers with DDU. RAM is running at 1600Mhz with 1x dual channel and 1x single channel (2x4GB, 1x8GB). Everything 1080p.

So my question is. What can be causing this low FPS on such a HW?
 
Last edited:

Metal Messiah.

Prominent
Mar 28, 2019
969
179
640
23
First thing I would like to advice you is try using some other Power supply unit/PSU, to re-test the GPU and your PC. Not saying that Fortron PSU is very bad, but if you can test your system by using some other PSU, then we can narrow down this issue.

Also, do not always compare your own benchmark results/FPS with others having a similar RIG as yours. Even though the specs might be exactly the same, but each system is different. There are many parameters/variables we need to take into account, when comparing two similar systems.

Is this your exact PSU model, or some other ?

https://www.fsp-europe.com/hyper-m-500600700w/
 
May 13, 2019
9
0
10
0
First thing I would like to advice you is try using some other Power supply unit/PSU, to re-test the GPU and your PC. Not saying that Fortron PSU is very bad, but if you can test your system by using some other PSU, then we can narrow down this issue.

Also, do not always compare your own benchmark results/FPS with others having a similar RIG as yours. Even though the specs might be exactly the same, but each system is different. There are many parameters/variables we need to take into account, when comparing two similar systems.

Is this your exact PSU model, or some other ?

https://www.fsp-europe.com/hyper-m-500600700w/
Yes, thats my PSU. Sadly i dont have any other PSU that would cover 1080 draw so this option is prob. not possible for me, to test if my pc.
 

knickle

Distinguished
Jan 25, 2008
188
5
18,695
3
If you know what you are doing and don't mind experimenting, I would remove the single stick of 8GB Ram and retest. I'm not a fan of mixing modules the way you have as it can lower memory performance. I believe the correct memory slots to use are DIMM 2 & 4 when you are using two identical modules on that board.
 
May 13, 2019
9
0
10
0
If you know what you are doing and don't mind experimenting, I would remove the single stick of 8GB Ram and retest. I'm not a fan of mixing modules the way you have as it can lower memory performance. I believe the correct memory slots to use are DIMM 2 & 4 when you are using two identical modules on that board.
I had only dual chanel 2x4GB running week ago, but its so low, i could barely set my games to high since they are taking alot more RAM, i had to borrow that 8GB stick from my uncle to be able to push games harder. Im also not fan of doing this but im at no-money atm so i can afford anything, need to wait to sell few of my old HW so i can afford used 2133MHz since they dont sell anymore.
 
May 13, 2019
9
0
10
0
Replace the PSU with a good quality one.
Do you really think this might be the main reason? Im not really happy seeing this, that i have to get new PSU since i have no-spare money but i belive it might be ONE of the reasons since its 3 years old PSU running in my previous PC mostly 2 days straight (than night off and again, but not every time it was running 2 days straigt, sometimes it was off for long time) because of idleing on rendering videos and downlanding games since my internet sucks.
 
Do you really think this might be the main reason? Im not really happy seeing this, that i have to get new PSU since i have no-spare money but i belive it might be ONE of the reasons since its 3 years old PSU running in my previous PC mostly 2 days straight (than night off and again, but not every time it was running 2 days straigt, sometimes it was off for long time) because of idleing on rendering videos and downlanding games since my internet sucks.

It's a low end PSU being used with a high end GPU, that's never a good idea, that's NEVER.

Needs to be replaced and a PSU needs to be 550W, one that's really a 550W PSU.

Unlike the one you have now that is really a 450W PSU if it can really even do that much.
 
Last edited:
Reactions: Metal Messiah.
May 13, 2019
9
0
10
0
It's a low end PSU being used with a high end GPU, that's never a good idea, that's NEVER.

Needs to be replaced and a PSU needs to be 550W, one that's really a 550W PSU.

Unlike the one you have now that is really a 450W PSU if it can really even do that much.
Thanks for tip anyway... Sadly im not able to get my self new PSU so i guess gaming have to wait.
 

knickle

Distinguished
Jan 25, 2008
188
5
18,695
3
Before running out and buying more hardware, you should install 3dmark (free version) and run the benchmark. It lets you compare your results with others that have the same GPU and CPU as you. If you dig into other peoples results you can see what their clock speeds and memory speeds are. You might find something that you overlooked.
 
Reactions: Boowy
May 13, 2019
9
0
10
0
have you tried running with system with dual channel config? some of the game you list down should be fine even with only 8GB RAM. also you might want to try disabling Hyper Threading for your i7 and see how does it affect performance.
Yes, i did and all of the games mostly used 9GB of RAM or 7GB which meant i had to lower graphics settings, or i couldnt alttab otherwise my windows die. Im now downing 3D mark and hopefully that will give me some results.
 
May 13, 2019
9
0
10
0
It's somewhat average for what you have. The record for your CPU and GPU is 8100. That's with major overclocking, and system memory at a scorching 2800MHz!

Use the advanced search and you can view all the scores for your combination. https://www.3dmark.com/search

Click Details next to the score you want to view.
Well i have just tried benchmark from userbenchmarks and this is what ive got, and i strongly belive this might be majour issue with my performance View: http://imgur.com/gallery/mdk72ue
 
May 13, 2019
9
0
10
0
That screenshot seems to indicate that your 8GB stick is at 1333Mhz, and the 4GB are at 1600Mhz. That's kinda odd.
Well that is odd since 4GB are actually 1600 but 8GB is 1866Mhz locked at 1600Mhz. But that doesnt matter anyway... im gona get my self 2133Mhz ram and delid my cpu so i can do some serious OCing and push my cpu to 2400mhz limit. Also gona prob delid my gpu since i started noticing higher temps around 78°
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS