2x OCZ Vertex 2 SSD's in Raid 0 - Sickening performance? maybe not...


Apr 22, 2007
Hi Folks,

I'm at a bit of a loose end here, and I've totally no idea where else to go with this, I hoped some genius here might be able to point out my error...

Firstly my system specs are:

Motherboard: Gigabyte GA-790XT-USB3
CPU: AMD Athlon II X3 445 @ Stock
RAM: G-Skill 4gb PC3-12800 (1600mhz DDR3)
GFX: HIS HD 5770
HDD: 2 x Ocz Vertez 2 60gb in Raid 0
HDD: 500gb Sata drive
PWR: Corsair TX650

Which interestingly is very close match to the $750 August gaming PC by tom's. Though i managed to build it over here, and also be able to splash a bit here and there, Hence my vision of the dream of not one of these amazing drives but two? two in raid? That's madness surely? like some distant dream of a computer that never hangs, never waits for a second, the drives supplying so much information it would be simply ridiculous to even comprehend what it would be capable of, kind of thing.

Of course I'm dramatizing it... but this is what it meant to me, finally the dream come true and all that.

I've basically had trouble getting this raid array to a)work and b) work properly.

To begin with, when i installed the drives, and after i configured them as a raid in the BIOS and also in the setup utility.. when I tried to install the OS (Windows 7 Ultimate 64 bit) it wouldn't recognize that a drive was there.

I quickly learned that it was my error, and I had just failed to install the raid drivers, it even had a section in the manual and everything. Felt like a total dunce right then. So i loaded the 64-bit drivers from the manufacturers website, the most up to date ones I could find, made especially for 64-bit windows 7... to allow you to see the drives in boot, in order to then install windows on them.

And it didn't work.

Basically, i installed all the drivers that came with the motherboard, and then, only when I installed the x86 RAID driver did it show.

Now this is me installing the 64 bit version of windows on a 64 bit processor, suddenly, the only way I can view this raid array in boot, and thus the windows setup, was to install the x86 driver.

It wasn't a fluke either, I tried this several times, and the only way I was able to see the disk was to install that x86 driver. I tried it installing every other one, except that one, and again, it only showed it when i loaded the x86 drivers I tried it also with just the x86 driver, and it pops up straight away.

Anyway, so eventually I just gave up thinking about it and installed the os anyway.

Now, I've had one of these on their own in a fresh install of windows 7 64 on a solid state, it is quick. Its so slick it puts macs to shame. no hanging around here, everything was done, instantly.

So i was expecting the world... but I have to admit, I am rather underwhelmed, it is definately slower then before.

So much so it lead me to downloading some disk benchmarking software and doing some tests.

Now, these drivers are supposed to do
- Maximum Read: 285MB/sec
- Maximum Write: 275MB/sec
- Sustained Write: 250MB/sec (source: these are the manufacturers stated specifications for this drive, availiable on their website : www.ocztechnology.com)

On their own, now it's worth saying I haven't tested these on their own on this computer yet, however, this supposed raid array is reporting 219mbps on read and 248mbps on write.

Now even if you allow for the bit of leeway, the old... what you see is not what you get, as we all know the actual reality is you get far less then they indicate, instead you can expect say a 20% knocked off at least. even allowing for that these drives should be pushing 400mbps each way at least?

So i've thought of everything it could be... I've checked the wires, they're good, I've checked the BIOS, it's all as the books should say, I've checked the BIOS that's OK, I'm only left with four things.

One being that it was the funny driver I had to install due to the RAID array

or Two being that there is a problem with the OS

Now the OS I came to after i bought the ultimate version of windows 7, because whilst the other OS's have separate CD's for their 32 bit and 64 bit versions, the ultimate version has only one... just casting a doupt in my mind, call be old fashioned... but that seemed like a bit much you know? Why would the fullest featured OS of the line also be the smallest?

Or three being that it's a crap onboard RAID card, and maybe should I invest in a RAID card?

I've never used RAID before, and I really don't know. It never seemed to make sense to me that there are these raid cards costing hundreds of pounds each, and yet it's available on any motherboard nowadays pretty much?

But i don't really know the big amazing world of RAID, as I said, it's my first foray into these kind of things...

So i'm stuck really, And i'm quite willing to play the elimination game... literally any second now... I have 4 days off, the house to myself and nothing else to do.... I'm staying up all night either way, But i thought some genius on here, some godly wizard of the art of RAID, would be able to point out what it is I'm doing wrong XD

Appreciate the help!




sub mesa

Apr 17, 2009
How did you test the performance of your RAID array? You cannot use HDTune for this. you would need:

- CrystalDiskMark

One of those two should be a lot better. Keep in mind that writing goes at 100MB/s; only if you write easily compressible data like zeroes will you be able to write at ~250MB/s. The physical NAND would only write a meg a second; so the 250MB/s is the speed of the controller; not of the NAND chips. The real write speed is 100MB/s; the rest is achieved with compression.

Also, your onboard AMD controller may not be very good. But please let us show benchmarks first? Post a CrystalDiskMark and AS SSD benchmark if you like, both are free programs.

Test with the file size set at 1000MB.