[SOLVED] 2x8gb Crucial Ballistix RGB 3200mhz issue with Asrock B450M Steel Legend

wint_17

Honorable
Jun 3, 2016
8
0
10,520
2
Hi,

Hope you can help with my concern.

Full Specs:
  • Ryzen 3 3300X OC'ed to 4.4ghz @ 1.375v
  • Asrock B450M Steel Legend
  • Sapphire Nitro+ 6600XT 8GB (Driver version 21.10.2)
  • 2x8gb Crucial Ballistix RGB 3200mhz (BL2K8G32C16U4WL)
  • WD SN550 500GB M.2 NVME
  • Samsung 860 EVO 500GB M.2 SATA
  • Seasonic M12II EVO 620W 80+ Bronze
  • Windows 11 Pro Version 10.0.22000 Build 22000
I recently bought a 2x8gb Crucial Ballistix RGB 3200mhz Memory kit (BL2K8G32C16U4WL).
I installed the two sticks in A2 & B2 slots for dual channel.

"4. We suggest that you install the memory modules on DDR4_A2 and DDR4_B2 for
Dual Channel Memory Technology."


So I enabled XMP, it automatically loaded the profile for 3200mhz CL 16-18-18-36 @1.35v, save the settings and reboot.
I got into windows, can see memory speed at 3200mhz and running in dual channel per CPU-Z.
Now I downloaded Ballistix M.O.D Utility to control the RGB and I can see that the kit is detected (SPD Data & Temps) but I cannot control the LEDs.

So I tried it with Asrock Polychrome still with no luck.
Tried with ASUS Armory Crate, when I opened the tool, this time around I can see the RGB went to static but colors are not sync.
But within the Armory Crate, it does not detect the kit.

So I went back to Polychrome, and luckily I was able to control the RGB, so I rebooted to check if the settings will stick.
After the reboot, the system did not post, fans are spinning the the memory RGB are all over the place.

Held the power button to shut-off the system and then turn it back on again.
The system posted, check bios configs, everything looks fine (memory still running with XMP 3200mhz @1.35v).

I booted to Windows again and now I can no longer see memory RGB being affected by Armory Crate or Polychrome.
At this point, it seems I cannot restart my system since it will not post after but from a cold start (complete shutdown) the system works fine.

So I decided to return the kit from where I got it and they tested it on a low-end intel board with only two RAM slots.
They didn't even tried to thoroughly test the kit e.g. tried a B450 board with 4 RAM slots to replicate the issue.

Long story short, based on their testing & store policy, they cannot replace the kit unless I bring the whole unit so they can see what the issue.
I convinced them that I'll just take a video clip of the whole issue and show it to them (by the way they are a bunch of crappy uncertified techs that doesn't know the specifics for their products).
So I went home and realized that I haven't tried putting the stick to A1 & B1 slots.

Lo and behold, kit are working as expected, kit runs in XMP 3200mhz CL 16-18-18-36 @1.35v.
Verified that they are running in dual channel via CPU-Z and I have full control of its RGB via Ballistix M.O.D Utility.
Although, it seems I'm unable to sync the RGB with Polychrome but who cares (I for one do not, just want to set the RGB to static mode)

So my question is, is it okay to keep it this way? Is my board faulty of the sticks are?

By the way, I forgot to mention above, when I got the kit, it seems the warranty seal from the box was already missing.
Another thing I raised with the store but they insisted that the memory kit is working fine.

Hoping for your response so I can record a clip of the whole issue and return the kit to the store and maybe they can replace the kit with a sealed one.
Or if it is okay to keep the kit and stick with this setup.

Just don't want to encounter any issue in the future.
I also saw a post with the same issue from AMD forum but appears not to be resolved:
https://community.amd.com/t5/processors/pc-won-t-restart-correctly-after-updating-the-system-memory/m-p/499208

Thank you.
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS