[SOLVED] 3 displays, 3 GPUs, 3 stuck pixels, I'm flummoxed.

johnrob

Honorable
Nov 22, 2014
87
1
10,645
2
I have a strange issue.

I have had an intermittent stuck pixel appear on each of 3 different displays, using 3 different GPUs (and cables). All stuck pixels will go away if I leave the monitor off for a while, but seem to come back any time I play a game for any length of time.

The first one appeared in the bottom 1/4 of the screen near the middle, and was stuck green. This was on an older Acer 24" 1080p 144hz monitor over DVI with a 980ti.

The second one appeared near the top left of an AOC 24" 1440p 144hz display, over Display port with the same 980ti. It was also stuck green.

Both issues were the same when using the iGPU and coming out of my motherboard, only I had to use an HDMI cable for the older Acer monitor.

I recently received a newer Acer 25" 1080p 240hz monitor, and a 5700xt. I used the included Display Port cable that came with the monitor and I see a stuck blue pixel in roughly the same place as the other Acer monitor (bottom 1/4 of the screen near the middle).

Is this a weird coincidence? Did I just get unlucky and need to return this monitor as well?

I'm not sure where to start troubleshooting here if it's some kind of other electrical issue, has anyone experienced anything similar?
 

cin19

Titan
Moderator
You may try this method to repair a stuck/dead pixel, I don't try it/use it so that I don't know it works or not. If it does not work, you may consider to return/exchange the new monitor.
 

cin19

Titan
Moderator
You may try this method to repair a stuck/dead pixel, I don't try it/use it so that I don't know it works or not. If it does not work, you may consider to return/exchange the new monitor.
 

James9002uk

Commendable
May 30, 2017
42
2
1,535
0
Check the cables, swap them out... maybe they are faulty in some way.

If you have a dead pixel and the monitor is in warranty still, contact the manufacturer/seller they should send you a new one.
 

johnrob

Honorable
Nov 22, 2014
87
1
10,645
2
Check the cables, swap them out... maybe they are faulty in some way.

If you have a dead pixel and the monitor is in warranty still, contact the manufacturer/seller they should send you a new one.
Each monitor that had a stuck pixel had a different cable. I've also tried them on 3 different video output sources so I'm just thinking I hit an unlucky streak with monitors.

could be that I'm buying budget displays as well, don't have money for a $350+ panel
 

ASK THE COMMUNITY

TRENDING THREADS