Question 3000 MHZ DDR4 Rams works at 2133 MHZ

May 30, 2021
5
0
10
0
Hello I was using 8 X 2 = 16 GB 3000 MHZ DDR4 Rams at full speed with any errors. I bought 2 X 16 GB =32 GB 3000 MHZ Kit as an extra. Both of them are Corsair.

Now the rams are just working at 2133 MHZ. When I make XMP enable, bios gives error and makes my ram speed work at 2133 MHZ.

I am using these rams on MSI Z170A Tomahawk Mainbord (Bios version Date 30/06/2018) with Intel I7 6700 K CPU.

How can make these rams work at 3000 MHZ ?

I am sending the properties of my rams below. I hope anyone can help me to solve this problem

 
Easiest is just removing 2x8GB modules from the system and working with 2x16GB config.

If your workload actually requires all 48GB of ram, then you'll have to do some manual fine-tuning.
Set your ram to 2400mhz, 15-17-17-35, 1.35V and test it.
Next try 2666mhz, 1933mhz,3000mhz. Test after each step.
When system is not stable anymore, then go back to previous ram frequency.
 

bignastyid

Titan
Moderator
You are mixing ram, which is not recommended, one of the reasons you don't want to mix is for what you are seeing. They will only work on jedec speeds(2133). Remove the old 16gb kit and only use the new 32gb kit then re-enable XMP.
 

DSzymborski

Titan
Moderator
I need both kits my friends. I can't remove any modules.
If the need is this crucial, then return the new RAM you bought and get a proper 2x32 or 4x16 kit. Mixing and matching RAM is very hit-or-miss, and from what it looks like, it's a miss in your case.

And manually overclocking, whether it's RAM or CPU or GPU is something you do yourself with incremental changes. Don't just slap in someone else's settings; if that's the choice, it's better to not overclock in the first place and risk your components.

No two sticks of RAM or two CPUs or two GPUs are truly identical. Even RAM sold together is merely tested together as working, not actually identical. Someone could very easily have identical models to you in every single aspect and still get different overclocking results.
 

InvalidError

Titan
Moderator
Having to lower the memory clock and possibly loosen timings is a common trade-off when using more DIMMs. Reload the XMP profile and dial the memory clock down until you get it stable. With some luck, you may be able to run something like 2866MT/s.
 

ASK THE COMMUNITY

TRENDING THREADS