Question 3080 locked at 75hz

Josh Satto

Honorable
Dec 20, 2014
17
0
10,510
0
I have a Lenovo y27q-20 monitor. My GPU is the Gigabyte Gaming OC. I have been playing consistently at 165hz for a few months. Yesterday, I decided to play Metro Exodus, and I noticed the monitor locked it at 74 fps. I restarted my PC and realized all my games were now locked below 75hz. I went into the Nvidia control panel, and I don't even have the option to select above 75hz anymore. I have the latest drivers now, but the problem started with the old one. The OSD does not determine the refresh rate--so that isn't the issue. I updated my monitor to the latest software, and still nothing. I am using a DisplayPort cable, and I've tried to separate them.

Any ideas or tips?
 
I have a Lenovo y27q-20 monitor. My GPU is the Gigabyte Gaming OC. I have been playing consistently at 165hz for a few months. Yesterday, I decided to play Metro Exodus, and I noticed the monitor locked it at 74 fps. I restarted my PC and realized all my games were now locked below 75hz. I went into the Nvidia control panel, and I don't even have the option to select above 75hz anymore. I have the latest drivers now, but the problem started with the old one. The OSD does not determine the refresh rate--so that isn't the issue. I updated my monitor to the latest software, and still nothing. I am using a DisplayPort cable, and I've tried to separate them.

Any ideas or tips?
Are you using vsync or what ever nvidia called it
 
Jul 24, 2021
16
0
10
0
Interesting...

Have you taken a look inside the Nvidia control panel? If the OSD isn't determining the refresh rate perhaps that is? I know that in 'change resolution' you can alter your monitor's refresh rate and even limit it via 'Max Frame rate' found in 'Manage 3D settings'
 
Jun 22, 2021
26
4
45
1
Have you tried using Windows Settings? Open it and then scroll down and find a link for "Advanced display settings". Open that and you should see an option to set the refresh rate. Check to see what that is set to.

Also, is your monitor appearing as a Lenovo in the Display settings or is it something like "Generic PnP Monitor". If it's the latter then it might be worth grabbing the Lenovo monitor drivers and installing them.

https://pcsupport.lenovo.com/au/en/downloads/ds540411-lenovo-y27q-20-monitor-driver-for-microsoft-windows-7-10-32-bit-64-bit

It might also be worth checking your monitor firmware.

https://pcsupport.lenovo.com/au/en/solutions/ht511642
 
I have a Lenovo y27q-20 monitor. My GPU is the Gigabyte Gaming OC. I have been playing consistently at 165hz for a few months. Yesterday, I decided to play Metro Exodus, and I noticed the monitor locked it at 74 fps. I restarted my PC and realized all my games were now locked below 75hz. I went into the Nvidia control panel, and I don't even have the option to select above 75hz anymore. I have the latest drivers now, but the problem started with the old one. The OSD does not determine the refresh rate--so that isn't the issue. I updated my monitor to the latest software, and still nothing. I am using a DisplayPort cable, and I've tried to separate them.

Any ideas or tips?
Generally it locking at 75hz is you using vsync or freesync whatever it's called for nvidia
 

SoumithCS

Prominent
Oct 6, 2020
60
10
545
1
Yeah if you enable Nvidia's G-Sync or V-Sync in game or in Nvidia Control panel, the GPU sync the refresh rate of monitor with the maximum frame rate delivered in-game to avoid screen stuttering and tearing . Metro Exodus does need a lot of GPU power if you want to play at higher res or more detailed environment. If you disable the V-Sync option in-game and disable G-Sync option in Nvidia Control panel everything should be back to normal.
 
Jun 22, 2021
26
4
45
1
Actually advanced sync (or g-sync) in the Nvidia settings should be on but V-Sync should be off. That should give you back your variable refresh rate. If you turn off the advanced sync you'll potentially get screen tearing.
 
Reactions: white.a.drew
Actually advanced sync (or g-sync) in the Nvidia settings should be on but V-Sync should be off. That should give you back your variable refresh rate. If you turn off the advanced sync you'll potentially get screen tearing.
.... Thank you.... I don't use rtx cards anymore and I still know this.... Rtx is over rated for the price it is right now id rather sell all my cards for a profit then waste time money and effort with all the new stuff.... Stick with your old gpu it will serve you well till the gpu market drops again.
 

ASK THE COMMUNITY