Question 3080 rtx wont give output

Oct 28, 2020
7
0
10
0
Hey guys, im the "happy" or rather maybe unfortunate owner of a gigabyte 3080 rtx gaming oc.
I seem to have some issues with getting the thing to work tho and i cant figure out till the point i think im gonna RMA it.

The problem is as following:
I took out my 2080 super aorus waterforce, and inserted the new 3080rtx in the PCIe slot thats on my mobo.
I attached 2x 6+2pin splitter cables to it and turned my pc on.
The fans spin, rgb lightning kick on but i get NO output to my screen and dont seem to be able to do much for the rest.

Anyone can sort me out with this?

Specs x570 aorus xtreme
32gb ram bios setting OC to 3600mhz
3900xt cpu
1000 watt corsair modulair psu (hx1000i)
 

curley81

Great
Sep 12, 2020
63
6
65
7
is this happening all the time or after a few attempts works? when i installed new msi sea hawk rtx 2080 had problem for a while of taking a few attempts to get signal problem doesn't happen anymore and only lasted a week or so not sure what it is but if it does start up after a few attempts leave it a week or 2 and see if its still happening

also happened to my friends PC when i installed my old GTX 1070 in his PC
 
Oct 28, 2020
7
0
10
0
ok i resolved MY issue, i was using a pci riser extension cable. they DO NOT support pci 4.0 and only 3.0.
you can change ur MOBO to pci 3.0 in bios OR remove the cable. i removed the extension cable and plugged straight to motherboard to solve this.
 

ASK THE COMMUNITY

TRENDING THREADS