Question 3080 Ti no longer giving a display ?

May 13, 2022
4
0
10
0
Specs,
Motherboard Aorus- z690 master LGA 1700.
CPU core I9-12900KS,
RAM- aorus I forgot the kind. DDR5
GPU 3080 Ti Aorus master
PSU- 1200

I've built my second computer and the issue is the 3080 Ti GPU no longer displays. . I've installed a 2080 instead and that works. I've even tried the 3080 Ti on another board and it is not being detected on any motherboard. I waterblocked it. I had to replace some thermal pads cause I used the 2.0 and not the 1.5 by accident and made the gap to big. After replacing the thermal pads and reinstalling the 3080 Ti GPU it started to not display or be picked up.

All my other parts are fine. I'm thinking that with uninstall/reinstall of the GPU I have may be messed up the GPU bios? Or maybe my motherboard won't register it? It's not displayed in the PCIE slot in the start up bios. I've even unplugged the PCIe power cables and turned on the pc with GPU installed to get an error but nothing happen. Card lights up and it shows connected to the PCIE slot because the lights come on above the power plugs. But still not detected in device manager or bios ?
 

Zerk2012

Titan
Ambassador
Specs,
Motherboard Aorus- z690 master LGA 1700.
CPU core I9-12900KS,
RAM- aorus I forgot the kind. DDR5
GPU 3080 Ti Aorus master
PSU- 1200

I've built my second computer and the issue is the 3080 Ti GPU no longer displays. . I've installed a 2080 instead and that works. I've even tried the 3080 Ti on another board and it is not being detected on any motherboard. I waterblocked it. I had to replace some thermal pads cause I used the 2.0 and not the 1.5 by accident and made the gap to big. After replacing the thermal pads and reinstalling the 3080 Ti GPU it started to not display or be picked up.

All my other parts are fine. I'm thinking that with uninstall/reinstall of the GPU I have may be messed up the GPU bios? Or maybe my motherboard won't register it? It's not displayed in the PCIE slot in the start up bios. I've even unplugged the PCIe power cables and turned on the pc with GPU installed to get an error but nothing happen. Card lights up and it shows connected to the PCIE slot because the lights come on above the power plugs. But still not detected in device manager or bios ?
Sounds like warranty time for the 3080ti.
 
May 13, 2022
4
0
10
0
Why would you need to flash the BIOS on a new card?

Your not going to mess them up installing it and reinstalling it.
The card doesn't work in 2 different PC's that is enough for me.
Because 1800 bucks on the line 😅 and who knows how long of a wait for a replacement. Plus, what if it works?
 

ASK THE COMMUNITY