[SOLVED] 3080 Underperforming?

Dec 20, 2020
4
0
10
0
Hi all, I picked up a Strix 3080 a few weeks ago, and ever since, my performance has been subpar

I've been averaging 80-100fps in warzone at 1440p on every setting (low-ultra) when benchmarks online with the exact same hardware as me have been averaging 150-200. My temps are also sitting at 60-68 degrees when I game and my CPU does not exceed 75 degrees. Moreover, I seemed to have gotten nearly the exact same performance with my EVGA 2080ti prior to the upgrade. I have done some research online and a select few individuals have been facing the same issues as me. At this point, I am thinking it may be best to submit an RMA ticket with ASUS. Any suggestions would be helpful!

Here's a benchmark of my system.

Specs:
  • Strix 3080
  • Asus ROG Maximus x Code
  • Intel i7-8700k
  • 32 GB Ram
  • Asus Rog 750W PSU (maybe this is the problem?)
  • Lian Li o11 Dyanmic (9 Case fans, so airflow shouldn't be an issue).
Solutions I have tried:
  • I have 3 8 pin PCI-e connectors going into the GPU
  • I’ve tried changing my power settings to maximum performance and the problem persist
  • I've done a DDU
  • Changed RAM profiles to XMP in Bios
  • Updated BIOS
  • Updated Windows
  • Updated to the latest GeForce drivers
  • I am running my games on an m.2 SSD and an internal SSD; so hard-drives are not the issue.
 
Hey, I reset my bios and though this gave a small boost to performance, my CPU is still benching at 88.8%.

Link to benchmark: https://www.userbenchmark.com/UserRun/37275992
You still have that RAM situation to fix. Your mixed up RAM configuration is defaulting to 2133mhz. Remove the sticks in a1-b1, reset BIOS.

Now you need to make sure turbo is enabled in BIOS so your CPU will boost properly.
 
Last edited:
Hey, I reset my bios and though this gave a small boost to performance, my CPU is still benching at 88.8%.

Link to benchmark: https://www.userbenchmark.com/UserRun/37275992
You still have that RAM situation to fix. Your mixed up RAM configuration is defaulting to 2133mhz. Remove the sticks in a1-b1, reset BIOS.

Now you need to make sure turbo is enabled in BIOS so your CPU will boost properly.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS