32 GB Drive Limitation

G

Guest

Guest
Hello all - first post on this board so please be gentle!

Hope someone can help. I have just purchased a Maxtor Diamond Plus 40GB 7200rpm, running off a Gigabyte BX motherboard (A really old BX board with the latest bios revision), and using Windows ME (I know... should have stuck with 98SE at least!). No problems with that, however I seem to only be able to see the first 32GB of the drive!?!

I am using Fdisk to try and create a single 40GB partition, but it can only see 32GB. Even when I have tried to split the partition 20GB/20GB I can only see 20Gb/12GB.

What I would like to know is :
1) Is this a limitation on my MB Bios or on Fdisk?
2) Is there a way around the problem WITHOUT changing hardware?
3) If it is a BIOS limitation, do all new MB circumvent this limit (i.e. if I buy a new mothboard I can get round this problem)

4) As a sideline question is there any downsides to have a single 40GB partition (loss of speed, losing hard drive space?)

5) and finally.... I do not use any bus-master drivers in Windows ME. Would I get a big performance boost I started using Intel BS drivers. Are there any potential downsides / incompatibilities whilst using it?

Thanks - especially if anyone can help!
 
G

Guest

Guest
If it's an Award bios (I imagine it is), you will probably find your answer here.

http://www.maxtor.co.jp/technology/q&a/30004.html

Award had some problems with their bios addressing drives above 32GB. They have fixed it, but Gigabyte might not have incorporated that fix into a bios update.

This is not a WinME problem. True all versions of Win95 can not address drives above 32G.. I don't really know why. But Win98 (with a patch) and WinME do not have this particular problem. I've never read anything that says why.. Microsoft doesn't say way. Probably just a coding thing and they don't want to mess with a fix for Win95 OS.


***Hey I run Intel... but let's get real***
 

ASK THE COMMUNITY