Question 3700X Is this normal?

craggle58

Honorable
Jul 11, 2014
45
0
10,530
0
I have just built a new system and I am having poor benchmark results. When my 3700x is under load the PPT and EDC readings in AMD Master Utility are completely maxed out . My cores are all capped at just over 4.0 ghz as well. The CPU temperature seems fine. Is this normal?
 

craggle58

Honorable
Jul 11, 2014
45
0
10,530
0
HI sorry for delay my specs are :

Ryzen 7 3700x
Dark Rock 4 CPU cooler
Gigabyte Aorous Elite X570
16gb Crucial Ballistix Sport @ 3200
Gigabyte 2070 Super Windforce OC 8GB
Adata 1TB NVME SSD + 1TB Samsung 860 Evo Sata SSD
Corsair RM750W PSU
NZXT H500 case

I am using a clean install of windows 10 Home with the latest bios update ABBA. I am not sure about the chipset drivers as I have just sent the GPU back so not running the system at the moment. I expect they are up to date as it was only built a couple of weeks ago. I am not getting any issues other than slightly rubbish benchmarks. It just looks a bit alarming in Master utility.

Benchmarks are:
Userbenchmark Graphics Score 113%
Heaven (ultra settings at 1440p) Score 2272 (FPS 90.2)
Timespy 10022
Firestrike 21485
Superposition 12331(1440p) 6226 (1080p extreme)
 
Last edited:
HI sorry for delay my specs are :

Ryzen 7 3700x
Dark Rock 4 CPU cooler
Gigabyte Aorous Elite X570
16gb Crucial Ballistix Sport @ 3200
Gigabyte 2070 Super Windforce OC 8GB
Adata 1TB NVME SSD + 1TB Samsung 860 Evo Sata SSD
Corsair RM750W PSU
NZXT H500 case

I am using a clean install of windows 10 Home with the latest bios update ABBA. I am not sure about the chipset drivers as I have just sent the GPU back so not running the system at the moment. I expect they are up to date as it was only built a couple of weeks ago. I am not getting any issues other than slightly rubbish benchmarks. It just looks a bit alarming in Master utility.

Benchmarks are:
Userbenchmark Graphics Score 113%
Heaven (ultra settings at 1440p) Score 2272 (FPS 90.2)
Timespy 10022
Firestrike 21485
Superposition 12331(1440p) 6226 (1080p extreme)
Once you get the CPU installed be sure to update to the latest chipset drivers and only use ones you download from the AMD site to be sure you get the very latest.
 

craggle58

Honorable
Jul 11, 2014
45
0
10,530
0
I built the computer myself (first time) but couldn't get it to post so took in to a local pc store (they said it posted first time so couldn't understand it and I missed out on the best part of the build ). They finished everything up including installing Windows and drivers etc for a fee. Is the PPT and EDC maxing out a major issue? I will have to wait a week for the GPU to be RMAed. Could it be a faulty mobo?
 
I built the computer myself (first time) but couldn't get it to post so took in to a local pc store (they said it posted first time so couldn't understand it and I missed out on the best part of the build ). They finished everything up including installing Windows and drivers etc for a fee. Is the PPT and EDC maxing out a major issue? I will have to wait a week for the GPU to be RMAed. Could it be a faulty mobo?
No, not major issue as long as everything's cool.
 

craggle58

Honorable
Jul 11, 2014
45
0
10,530
0
Its not going to fry my VRMs or CPU socket then? This build has been a bit chaotic. I have ended up having to RMA my GPU and monitor. Not to mention the trouble of not getting it to post (I think I simply forgot to change the monitor input from DVI to HDMI).
 

ASK THE COMMUNITY

TRENDING THREADS