Question 3950x High temperature

rikoma17

Honorable
Jan 15, 2015
28
0
10,530
0
Hey guys,
Just got a 3950x and no matter what I seem to do it the temperature is always really high.
The idle temps are between 60 to 70 degrees with nothing but Ryzen master. I've tried to lower the voltage but that doesn't seem to affect it. When I run cinebench r20 it pegs it at 95 degrees and throttles down to 1.8ghz giving me a cpu score of 4700.
I upgraded from a 1700x and never had an issue with it before
Specs:
Ryzen 9 3950x Corsair h110i gt Asus crosshair vi hero -x370 Bios :7901x64
Any idea of a fix or is it just a dead CPU!!
Thanks in advance

UPDATE:
without me changing anything I turned it on today and the idle temps are bellow 40 degrees and max out at 65 degrees in cinebench r20 giving me a score of 7300 at 4.1Ghz. No idea what has happened
 
Last edited:

rickypicky5

Notable
Sep 9, 2019
543
63
1,040
31
ive tried to reset it a few times and it seems to be in place never had an issue mounting it
Did you clean the thermal compound from the heatsink when you removed it from the old CPU? Did you re-apply fresh thermal compound to the CPU prior to putting the heatsink back on? Are you sure you connected up all the wires coming from the AIO back to the motherboard/PSU?
 
Reactions: Zerk2012

rikoma17

Honorable
Jan 15, 2015
28
0
10,530
0
Did you clean the thermal compound from the heatsink when you removed it from the old CPU? Did you re-apply fresh thermal compound to the CPU prior to putting the heatsink back on? Are you sure you connected up all the wires coming from the AIO back to the motherboard/PSU?
i cleaned the thermal paster and reapplied the thermal paste, i have even tried it several times with different applications.

didn't unplug any of the cables as all I did was replace the CPU on a existing build
 

rikoma17

Honorable
Jan 15, 2015
28
0
10,530
0
Did you reset the CMOS after you put in the new CPU and it was still powered down? Then, when you powered it up, did you get into the BIOS and reset it to factory defaults?
yeah ive reset the BIOS several times now and put it at factory defaults, im starting to think its the cooler going to try a different one in the next few days
 

beorn

Distinguished
Nov 23, 2010
76
14
18,535
0
Hey guys,
Just got a 3950x and no matter what I seem to do it the temperature is always really high.
The idle temps are between 60 to 70 degrees with nothing but Ryzen master. I've tried to lower the voltage but that doesn't seem to affect it. When I run cinebench r20 it pegs it at 95 degrees and throttles down to 1.8ghz giving me a cpu score of 4700.
I upgraded from a 1700x and never had an issue with it before
Specs:
Ryzen 9 3950x Corsair h110i gt Asus crosshair vi hero -x370 Bios :7901x64
Any idea of a fix or is it just a dead CPU!!
Thanks in advance

UPDATE:
without me changing anything I turned it on today and the idle temps are bellow 40 degrees and max out at 65 degrees in cinebench r20 giving me a score of 7300 at 4.1Ghz. No idea what has happened
7300 is about what I get with my 3900X. Maybe something is still off but good temps are most important
 

ASK THE COMMUNITY

TRENDING THREADS