Question 3D apps crashing to desktop ?

May 17, 2021
2
0
10
0
Hi guys,

I got some used parts to upgrade my old PC but with any 3D application I get CTD a few seconds after opening.

Toubleshooting the issue I got some very inconsistent results. Here we go:

OLDPC:
Intel 7700k
Nvidia GTX 760 2Ggb
MSI x270 Gaming Pro Carbon
GSkill Trident Z 2x8gb 3600 cl16
Sata 6 SSD
LC Power 650w 80 bronze (old) PSU
(fresh install and up-to-date drivers and firmwares)

I used parts from my new PC to troubleshoot, here are it's specs:

NEWPC:
Ryzen 3600
Nvidia 2080 ti
Gigabyte X570 UD
GSkill Ripjaws 2x8gb 3600 cl16
Sata 6 SSD
XFX 850w PSU (by seasonic)

I swapped the RAM and the PSU and nothing changed. When I swapped the GPU the system worked fine!
So apparently the GTX 760 was bad, but I tested this card in the NEWPC and it worked flawlessly!!

So bottom line, I only get CTDs when I combine the 7700k+z270 with the GTX760, every other combination of components between both PCs works fine.

I tried mostly running kombuster and Quake champions, both CTD with no error message, just glitches then freeze then CTD.

Can someone help me?
 
Last edited:

iPeekYou

Distinguished
Jul 7, 2014
394
76
18,790
10
Try it on a fresh Windows install. My guess is either funky Windows behavior, or funky PCIE slot on the Z290.

You can also try DDU on the Z290 system, might be graphics driver issue as well. I recommend testing with fresh Windows install instead to eliminate as much variables as I can in one go. I imagine DDU is easier to do since we don't need to get off our asses to do that lol.

While Nvidia's driver support is miles ahead of AMD's, even my 1080 has minor issues with latest (stable) drivers. A guy on Youtube always mentioned his Kepler GPUs are finicky with newer drivers. Another guy in this forum that I replied to mentioned shutdowns with his 1070 Ti that the memory dumps revealed to be nvddlkmkm.sys (might misspell it, basically the Nvidia driver file).
 
May 17, 2021
2
0
10
0
Thanks a lot for your reply!

Here's what I did this time:
  • Unplugged from internet
  • Loaded bios default settings
  • Did a fresh windows install (eliminating partitions, etc...)
  • Installed the lastest nvidia drivers with an usb
  • Connected to the internet
  • Let windows update run
Same problem, however I did notice much more instability after I went back to BIOS and enabled XMP.
Also, that GTX 760 always had pretty audible coil whine, and I can hear it very clearly when I start to load it (can't tell if it's louder than before), suddenly coil whine stops and the program crashes. It might sound like the card is broken but I know if I pop it into my PC it will work like a charm.

I did try the other pcie slot in the z270, forgot to mention that in the first post!
 

ASK THE COMMUNITY