4 monitors on a single 1080Ti

Jan 6, 2019
4
0
10
0
Hi all. I'm getting an error when I plug my new 50 inch 4K UHD TV into my graphic card that say's, Weak HDMI Signal. I'm using a 5 meter 4K HDMI cable. I only intend to use the monitor too view applications on so it's not for gaming.
I also have 3 other monitors.
1 x 27 Inch @144Mhz = Gaming Monitor on Display Port
2 x 24 Inch @144Mhz = application screens on Display Port.
The 50 Inch screen has a Digital maximum resolution of 7680 x 4320. = application monitor on HDMI.

Can anyone tell me how to fix this issue?
I've checked the cable on it's own and it works fine and I've also used it on my streaming PC and it works fine as well.
I just get the error when connecting to my gaming PC

My GPU is a EVGA 1080Ti FTW 3 SC.

Any suggestions would be appreciated.

Strat.
 

Lutfij

Titan
Moderator
You may want to pass on the make and models of all 4 displays. You might also want to see what you get when you only have the TV hooked up standalone without the smaller monitors.

To add, please list the specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Since you spoke of two system, one for gaming and one for streaming, there should be two sets of specs.
 
Jan 6, 2019
4
0
10
0


I'm not using the other PC to stream at the moment. For now I just want all 4 monitors working.
 
Jan 6, 2019
4
0
10
0
CPU: Intel I7 8700k @4.3Ghz
Motherboard: asus rog strix z370-f
Ram:32Gb DDR4
SSD/HDD:Evo 960 M.2 500Gb, 3 x Evo 860 500Gb.
GPU:EVGA GTX 1080Ti FTW 3 11Gb
PSU:Corsair 750w gold
Chassis: Corsair Graphite
OS:Windows 10 64 Bit
Main Monitor ASUS MG278Q. The othe 2 monitors are also ASUS. 50 TV is Hisense 4K UHD
Since you spoke of two system, one for gaming and one for streaming, there should be two sets of specs.[/quotemsg]

I'm not using the other PC to stream at the moment. For now I just want all 4 monitors working.
 
Jan 6, 2019
4
0
10
0
Hi, I'm still unable to get the 50 inch monitor working when I have the other 3 plugged in. I'm using a dedicated 4K cable but it still says Weak HDMI Signal and I've tried 3 cables now.
Really not sure what to do next.
 

ASK THE COMMUNITY

TRENDING THREADS