Question 4 short beeps when starting pc, with Zotac 3070 Twin Edge OC

Jul 16, 2021
2
0
10
0
Hello, I recently purchased a new graphics card, Zotac 3070 Twin Edge OC, I have a pretty old pc but I've been using it with another Zotac GTX 1070 with no issue, the problem is that I connect this new card and I get 4 short beeps when starting, then it starts and works correctly apparently, it's just that noise at the start. I read many topics that it can be the CSM, I have a motherboard MSI B85M-G43. According to that motherboard, the way to disable it is to enable a special feature in the bios, in BIOS -> Settings -> Advanced -> Windows 8/8.1 Configuration -> Windows 8/8.1 Feature [Enabled]. This disables the CSM automatically. The problem is that if I do that, it boots into a Shell screen and I can't access Windows. I don't know if I should have to reinstall Windows completely, if this shell is something that the bios or windows is generating. I can also try to update the BIOS, but honestly I don't know how and I'd rather not risk it for now if it's just a mode I need to disable. I also checked the System Information in Windows and the BIOS is apparently in Legacy mode. I don't know how to set it in UEFI. Is there anything I can do? Thank you

CPU: Intel i7 4770 3.40ghz
MOTHERBOARD: MSI B85M-G43
BIOS MODE: Legacy
CARD: Zotac RTX 3070 TWIN EDGE OC 8GB
OS: Windows 10 Home 21H1 19043.1083
 
Jul 16, 2021
2
0
10
0
try reinstalling windows with CSM disabled and it will fix the beeping problem
Thanks I'll try that, for some reason this mother doesn't have an explicit CSM toggle, but according to that faq if I enable Windows 8 Feature in Advanced settings CSM is disabled automatically. Another thing I discovered was that the boot mode was set on LEGACY+UEFI instead of UEFI only, should I switch to UEFI and reinstall Windows? Thank you very much!
 

ASK THE COMMUNITY