Jul 17, 2008
I recently purchased a Radeon 4870 Powercolor card from NCIX. After installation, everything worked right apart from the sound. There was no sound anymore, despite the fact that all drivers were properly installed. I tried everything to fix it, including reinstalling the drivers, using the KB835221 hotfix, trying other drivers, disabling ATI external event utility service, etc. I checked the device managers in Sound, Video, and Game Controllers to see what's changed between my old card and my new card. The old card used "Realtek High Definition Audio", but that was replaced by "ATI Function Driver for High Definition Audio - ATI AA01" after I installed the 4870. I was told that the "Realtek High Definition Audio" was the onboard audio of my mobo, so the sound stopped working due to this audio conflict. Does anyone know why it was replaced, or how to fix this?

Try this:
Download the newest drivers from the motherboard manufacturer, there should be two packages, the Realtek drivers and the Windows high definition(Azalia) driver.
Uninstall the Realtek drivers and reboot into BIOS and check the Azalia is still enabled then restart into Windows.
Install the Realtek drivers.
Install the Azalia drivers.
I had the same problem with my HD4870 and GA965P S3 board and installing just the Realtek drivers did not work untill I added the Azalia drivers, which was strange because the Realtek package supposedly came with and installed the Azalia components!