• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question 4K display not working as my primary display ?

Shubham Deshpande

Honorable
Sep 8, 2014
8
0
10,510
0
I have a very unique and odd problem with my 4k display (27GN950). Everything was working well for a past couple of months when suddenly I started having issues with my GPU (6800xt) where whenever I started a game or benchmark my display became pixelated and stayed like that till I restarted and this happened with my older display as well. Which is why I replaced my GPU with a older one on hand and everything became normal.

A couple of days later I decided to try again with my current GPU and to my surprise two things happened. First let me tell the good one that benchmarks like Heaven started running normally but I haven't tried a game yet and lets hope the problem doesn't come back. But this came at a very odd cost which was the second surprise that my 4k display no longer works if I use it as the only display ?

At first it was working only on 1080p 60Hz and now it works only till post and then shows a Grey screen, mind you this only happens if its the only display connected. If I connect my older 1440p monitor then the 4k monitor also works at 4k 144Hz. Its so odd that the moment I connect the 2nd DisplayPort to the other monitor everything seems fine as a duplicate or extended display. But the moment I disconnect my 1440p monitor my 4k monitor becomes grey again. I have tried both the ports and both the cables with the 4k monitor but it just doesn't want to work on its own.

Not sure what I can do anymore, please let me know if anyone has any ideas.
 

ASK THE COMMUNITY