Question 5 beeps then works normally

Dec 9, 2022
5
0
10
0
My pc beeps 5 times then a delayed 1 beep before starting. It works perfectly like there's no issue. It only happen when I start it on cold boot but if I restarted it, it doesn't happen. I bought my pc on oct 1 2022 so it's very new.
It started to happen after I used the Optimization curve on Ryzen master. But I reset it and it still happens. I alsp did a cmos reset.

my specs are:

MOBO: ASrock b450m steel legends
CPU: Ryzen 7 5800x
GPU: Galax 1660 Super
SSD: NVME Crucial P2 1tb
PSU: Seasonic Core Gm650w
RAM: 2x8gb T-Force Delta R
 
Dec 9, 2022
5
0
10
0
It's a 5 beeps and the other beep is like a normal beep for post, I remove the CMOS battery for 2mins then put it back.
and for ram it's A2 and B2 and my bios version is
SMBIOSBIOSVersion
P4.30
 

Lutfij

Titan
Moderator
You could update your BIOS to the Beta version(4.31) or to the one after it and see if that alleviates the issue. Once you've successfully flashed the BIOS to the latest version, clear the CMOS with the battery out of the system for 30 mins, while disconnected from the wall and display.
 
Dec 9, 2022
5
0
10
0
I did it but it still happen, It only happen if I didn't use my pc for a day or a long time. But if i shut it down then turn it on again it doesn't happen. Is there any possibility that i damage my cpu?
 
Dec 9, 2022
5
0
10
0
I did it but it still happen, It only happen if I didn't use my pc for a day or a long time. But if i shut it down then turn it on again it doesn't happen. Is there any possibility that i damage my cpu?
Also my CPU hit 90C while I'm streaming. It stays in 90C for 3-5secs, then return to value of 80+C. So i did the automatic optimization in Curve Optimization of ryzen master, for some reason i had a random restarts, so i reset to default then reset cmos.
 

ASK THE COMMUNITY