Question 5700 XT Sapphire artifacting and causing issues

Aug 1, 2019
2
0
10
0
Hey guys. I'm pretty new to all this reddit thing.
I have recently purchased Sapphire 5700 XT (3 days ago) and i have problems with it.
I have used GTX 1060 6g before this gpu with zero problems. Installed new card and it had problems detecting my 3 displays. After i have installed Adrenalin app and installed most up-to-date drivers the gpu detected all 3 displays, but the picture went blue hue... Restarted the PC and the windows had problem loading up... getting stuck. Decided to reinstall windows fresh. After i launched the fresh windows and installed the drivers i decided to test the card in few games. In 3 out of 4 games tested, the card would artifact, make red, blue and green glares around the screens... like flashes of red green and blue lights... in game where that should not be there.
Yesterday, Windows asked for an update, so i selected a time for it to auto install the updates. When i came back in the morning, the PC was stuck on starting windows (with the white dots that run in circle frozen in place). I decided to take out the card and put my old 1060 in to check. Once i did that the PC started right away, and i have 0 problems since.
Was wondering if issues like that are known with 5700XT... can it be a defective gpu that i landed on?
My pc is:
i7-8700K
Gygabyte Z370-HD3
16Gb DDR4 2400
Antec 650 Watt PSU

Thank you all in advance!
 
Aug 1, 2019
2
0
10
0
Cables were inserted properly, those are DP cables so the sit in tight when inserted.
PSU is Antec 650 Bronze PSU VP650PM
 

ASK THE COMMUNITY

TRENDING THREADS