5770 - bad flicker

r4zorlive

Distinguished
Apr 19, 2010
22
0
18,510
0
After building my new system I've had problems with the graphics. I have an XFX HD5770 video card.

Opening any game (tested games are UT2004, NFS MW) the screen instantly starts flickering , to the point where it's impossible to see anything. Exiting the game shows the desktop with noise all over the screen. Tested with 10.4+10.5 drivers. Any ideas off the top of your head?

edit: I have a 550W Antec TP, graphics card is recognized, fan runs etc.
 

fisshy

Distinguished
Nov 25, 2009
429
0
18,810
11
Beware This is Canned

My solution: Again after much reading, I came to the conclusion that Windows 64bit was not playing nice with my 5870’s powerplay function. Mainly that the idling 157 clock speed was not enough to keep the card stable when idle. After updating the card’s bios, I could go hours without a crash when playing a game, but then it would crash after I was done, when it sat idle on the desktop.

I came across this solution that forces the card to idle (2D) at a higher clock. I had to set it to a clock speed that Windows 7 would be happy with. (For me this was 400 when idle, and the stock 850 when running games)

Steps:

1. Open CCC

2. Unlock and Enable Overdrive if they aren’t already.

3. Go to Options/Profiles/Profiles Manager. Create a new profile. Under composition make sure “ATI Overdrive” is checked. Save and Close, DO NOT ACTIVATE.

4. In windows go to: C:\Users\{yourusername}\AppData\Local\ATI\ACE\Profiles (you will need to have “show hidden files” turned on for this)

5. Open the xml document with the name of the profile you just created (notepad is fine)

6. Change the values of the Clock and Memory speeds to look like this (these specific values are what worked for me and my card, use judgment) EDIT ONLY THE BOLD VALUES.



Feature name="CoreClockTarget_0"

Property name="Want_0" value="40000"

Property name="Want_1" value="60000"

Property name="Want_2" value="85000"

Feature

Feature name="MemoryClockTarget_0"

Property name="Want_0" value="90000"

Property name="Want_1" value="90000"

Property name="Want_2" value="120000"



7. Save and close. Go back to CCC and activate the profile you just created.

This will make the card idle at 400core, 900memory. (2D clocks are the "Want_0" values)

Good luck Mate, if you cant Find the profile just search it on your PC
 

canadian69

Distinguished
May 1, 2010
605
0
19,060
33
What kind of monitor? Certainly sounds like the games are launching into an unsupported video mode. I would expect the game to exit and report this or for the monitor to just go to a no-signal state. Have you tried different resolution settings in the game configs? Make sure that your monitor is being detected properly in display settngs.
 

r4zorlive

Distinguished
Apr 19, 2010
22
0
18,510
0
Actually, before this started happening, the computer did have problems with displaying, it was on and working but the monitor all froze up. Tried different settings in configs. Monitor was detected, windows calls it a Generic PnP monitor.

It looks more like a graphics problem, it's the sort of flicker like there are models moving across the screen really fast and it's distorting them.

Possible it's the PSU not giving enough power?
 

fisshy

Distinguished
Nov 25, 2009
429
0
18,810
11
Have you Overclocked the cards?
Its a common problem With OC'd 5xxx Series Cards...

It could Also Be a Ram Issue (Read Up on it)

Read through This

And does it look like this?
 

r4zorlive

Distinguished
Apr 19, 2010
22
0
18,510
0
@ canadian69
Will try when I get to turn it on next - but I have this problem with 2 other monitors I've tried as well

@ fisshy
I haven't overclocked the card any - and that's not what is pissing me off in this instance, but that did happen a couple of times before - could the fix to that fix my problems aswell?

I don't think I've worded my problem right since I can't find a screenshot of anything similar to it
 

fisshy

Distinguished
Nov 25, 2009
429
0
18,810
11
@r4zorlive thats ohk...

Try using that fix and if it doesn't help Rma your Card... Its a faulty memory chip.
Whats worse is that i just built a Machine with The exact same card for a customer.

 

firebird

Distinguished
Nov 13, 2004
516
0
18,990
3
Create a profile in CCC that will keep the core and memory at 400/1000 during idle (may have to edit the profile). That worked for fixing my flicker with my 5850.
 

fisshy

Distinguished
Nov 25, 2009
429
0
18,810
11
Beware This is Canned

My solution: Again after much reading, I came to the conclusion that Windows 64bit was not playing nice with my 5870’s powerplay function. Mainly that the idling 157 clock speed was not enough to keep the card stable when idle. After updating the card’s bios, I could go hours without a crash when playing a game, but then it would crash after I was done, when it sat idle on the desktop.

I came across this solution that forces the card to idle (2D) at a higher clock. I had to set it to a clock speed that Windows 7 would be happy with. (For me this was 400 when idle, and the stock 850 when running games)

Steps:

1. Open CCC

2. Unlock and Enable Overdrive if they aren’t already.

3. Go to Options/Profiles/Profiles Manager. Create a new profile. Under composition make sure “ATI Overdrive” is checked. Save and Close, DO NOT ACTIVATE.

4. In windows go to: C:\Users\{yourusername}\AppData\Local\ATI\ACE\Profiles (you will need to have “show hidden files” turned on for this)

5. Open the xml document with the name of the profile you just created (notepad is fine)

6. Change the values of the Clock and Memory speeds to look like this (these specific values are what worked for me and my card, use judgment) EDIT ONLY THE BOLD VALUES.



Feature name="CoreClockTarget_0"

Property name="Want_0" value="40000"

Property name="Want_1" value="60000"

Property name="Want_2" value="85000"

Feature

Feature name="MemoryClockTarget_0"

Property name="Want_0" value="90000"

Property name="Want_1" value="90000"

Property name="Want_2" value="120000"



7. Save and close. Go back to CCC and activate the profile you just created.

This will make the card idle at 400core, 900memory. (2D clocks are the "Want_0" values)

Good luck Mate, if you cant Find the profile just search it on your PC
 

r4zorlive

Distinguished
Apr 19, 2010
22
0
18,510
0
Will try it soon. Incase this doesn't fix the problem and the card is faulty, does this void the warranty? (dated posts say it doesn't, clarifying)
 

Trueno07

Distinguished
Apr 15, 2009
508
0
18,990
1
When it says "Generic PNP monitor" that can mean that the drivers haven't been installed, or installed right.

Maybe try reinstalling the drivers before you have to RMA it?
 

fisshy

Distinguished
Nov 25, 2009
429
0
18,810
11
The monitor is p&p It doesn't matter what the monitor is.

As long As the Monitor Has out putted its Specifications (Lehman's Terms) To the drivers There shouldn't be any flickering or GSOD's

IF this Tab Looks like this in your Catalyst Then Everything is in check (Your Refresh rate should be 60HZ) [:fisshy:5]

 

ASK THE COMMUNITY