5770 crossfire black screen

zookeeper525

Distinguished
Jun 20, 2010
145
0
18,680
When i'm playing a game for a while, i keep getting a weird black screen flashing and sometimes the screen stays black for like 10sec. It's started doing it a lot more and i can't seem to figure out what is causing this to happen. It doesn't do it when i only have one card in, it kind of looks like when you first start a game and the screen flashes black for a sec while it opens the game window.

Anyone know what might be causing this?

I have amd catalyst 11.7 so it seems to be up to date, so i don't think it's that.
 

zookeeper525

Distinguished
Jun 20, 2010
145
0
18,680
I did as you said and it didn't do it when only one card was in it no matter what slot. I tired both cards and in both slots and it didnt do it.

switching the cards around crossfire did seem to make it do it A LOT less. It only flashes like once every 20mins now and the flash doesn't last more than a sec. it's still rather annoying though. Anyone know what might be causing this to happen? It's only doing it when i'm playing a game.
 

eyefinity

Distinguished
Mar 6, 2010
1,106
0
19,310
Could be a weak psu maybe. You are running 2 cards instead of 1 after all. It might even just be a weak pci-e cable, so if you have a spare one try it out on each. Also if you are running one of the cards pci-e cables off a molex connector then make sure it's connected to the dvd drive and not the hard drive.
 

eyefinity

Distinguished
Mar 6, 2010
1,106
0
19,310
I have no clue what's going on with that though but it could be a driver issue. Did you completely remove the old drivers first?

Sometimes you might just have to fresh install windows as well to get rid of bugs hanging around. It does look like drivers or software though based on your fraps.
 

zookeeper525

Distinguished
Jun 20, 2010
145
0
18,680
Yeah, i did some googling and it seems to be a bug with amd's drivers. People from over a year ago reporting the same issue i'm having and everything with bc2. I guess amd never fixed it.
 



yeah I couldnt stand it anymore, its pathetic do you notice any microstutter?
 

eyefinity

Distinguished
Mar 6, 2010
1,106
0
19,310
Yet very few people seem to notice these issues. I mean if this was a common problem don't you think it would be all over the web considering how many millions are playing the game on AMD hardware?

I can guarantee you that if you did a fresh install of windows the problem would go away.
 

zookeeper525

Distinguished
Jun 20, 2010
145
0
18,680
@jjb8675309
If it was a hardware problem wouldn't the hub for bc2 go black as well?

My psu is a rosewill performance series, i've had it for years and it's never failed me once. So i doubt it's my psu.

http://forums.amd.com/game/messageview.cfm?catid=279&threadid=136197

So it must be the drivers. I can't really do a fresh install of windows as i don't have the time to do all that.

Everything in that link is happening to me, from longer than normal load times for bc2, to the screen flashing.
 

eyefinity

Distinguished
Mar 6, 2010
1,106
0
19,310


Yeah it can't handle anything major at full settings but you'd be amazed at how well it runs some stuff that is a bit older. 3 screen and nearly max settings Fallout 3 + NV is amazing and stuff like shogun total war and Civ 5 generally runs around the 30 fps mark at reasonable settings.
 
Thats cool ive always wanted a tri monitor setup even if it was with a mid gpu config, I bet you can get some great frames on tri screens with valve and bethesda games like fallout nv.

Dude im done arguing with you I am just sharing my personal expirience, so lets just go on with a mutual respect if you dont mind, that will be a much better way of doing things on here- peace!?
 

eyefinity

Distinguished
Mar 6, 2010
1,106
0
19,310

eyefinity

Distinguished
Mar 6, 2010
1,106
0
19,310


Suits me mate. Just remember that when I am the sole defender of AMD on this board (which I am), I have to be this arrogant to deal with 5+ people in every thread. It's really nothing personal.
 
there are probably plenty of fixes out there that may or may not work but honestly your gonna go through all that to fix it, and then repeat after you restart windows... in my humble opinion it just does not make sense to settle for that, if anyone disagree that is okay but that is just my opinion